-
Knoppix + Qemu-ed SL images. Detailed explaination
Hi everybody.
I'm writing to search for help about a problem i'm experiencing.
I'm using knoppix as host system for a virtualized computing-grid testbed, implemented as two Scientific Linux (RHEL like) guests launched by the qemu emulator.
Two scenarios follow:
1) I boot a Knoppix "vanilla" system (which get access, when ready, to the local disks). As the system become ready, I install qemu, uml-utilites,bridge-utils (via apt-get), and I run qemu to virtualize two pre-installed Scientific Linux images (laying on my main physical disc). Everything goes ok.
2) I remaster Knoppix to include qemu/bridge-utils/uml-utilites and the two SL images. When finished, I restart the whole system and boot from the new, remastered, knoppix DVD. When the booting phase ends, I try to launch my qemu-ed images. Both of the images, when trying to chroot to /, fail with a bad kernel panic (with a different initial message).
Does someone know what is the reason for this to happen? Why this behaviour difference within the two previous environments?
I've to precise that both images are "mirrored": they have the same OS and Filesystem installed on.
Thank you in advance,
Alex.
N.B: Kernel Panic detailed messages are as it follows:
<FIRST RUNNED IMAGE>
Redhat nash version 4.2.1.8 starting
Mounted /proc filesystem
Mounting sysfs
Creating /dev
Starting udev
Creating root device
Mounting root filesystem
EXT2-fs: magic mismatch, very weird!
Mount: error 22 mounting EXT2
Mount: error 2 mounting none
Switching to the new root
Switchroot: mount failed: 22
mount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!
<END OF FIRST IMAGE MESSAGE>
<SECOND RUNNED IMAGE>
Redhat nash version 4.2.1.8 starting
Mounted /proc filesystem
Mounting sysfs
Creating /dev
Starting udev
Creating root device
Mounting root filesystem
VFS: couldn't find ext2 filesystem on dev hda1
Mount: error 22 mounting EXT2
Mount: error 2 mounting none
Switching to the new root
Switchroot: mount failed: 22
mount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!
<END OF SECOND IMAGE MESSAGES>
Similar Threads
-
By CytoTech in forum The Lounge
Replies: 0
Last Post: 09-22-2005, 07:37 AM
-
By mahdi in forum MS Windows & New to Linux
Replies: 1
Last Post: 02-09-2005, 05:10 PM
-
By rohandhruva in forum General Support
Replies: 0
Last Post: 11-11-2004, 07:02 PM
-
By fabioxa in forum Customising & Remastering
Replies: 0
Last Post: 07-05-2004, 08:16 PM
-
By Daishi in forum General Support
Replies: 2
Last Post: 02-15-2004, 04:28 PM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

Gigabyte 4U AI Server 10x Nvidia GPU 2x Xeon Gold 6150 36 Core 2.7GHz DDR4 RAM
$1625.00

Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD
$275.00

867959-B21 HPE ProLiant DL360 G10 CTO Server W/ 2x 865414-B21 1x 840140-001
$225.00

Microsoft Windows Server 2025 Standard 64bit 32 Core-50 CALs DVD With Key Sealed
$95.99

Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p
$499.88

Dell Poweredge R730xd 12LFF 2*2660v4 4*1Gbe h730 2x 750W Server CTO
$368.00

Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W
$409.99

Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb
$374.99

RDS CAL - Remote Desktop Services Windows Server 2019 50 User/Device Connections
$63.00

Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Core | HBA330 | No RAM or HDD
$169.99