I want to share directory between 2 knoppix systems.
I think that I didn't make any mistakes, but the problem was always happening.

First, I edited /etc/exports like this.

/home/knoppix 192.168.1.*(ro)

and I started portmap and nfs-kernel-server, and I checked showmount was OK.

I added the line allowing connect to portmap to /etc/hosts.allow

but whenever I tried to mount NFS, 'mount failed, reason given by server : permission denied' error message was kicked.

I tried to solve the problem, search and search.... So I tried /etc/exports like this.

/ramdisk/home/knoppix *(ro,no_root_squash)

and connected to localhost like this.

# mount -t nfs 127.0.0.1:/ramdisk/home/knoppix /mnt/nfs

but the same error occured.

How can I solve it?




--
大逆戰