Results 1 to 7 of 7

Thread: Error setting up re-master session

  1. #1
    Junior Member registered user
    Join Date
    May 2007
    Location
    Southern California
    Posts
    11

    Error setting up re-master session

    Hey guys,

    I have a re-master session going. I copied all the files over, and upon issuing the bind commands before the chroot, I get an error when binding the /dev directory. It says that the file system is wrong. Is this a familiar error you can help me with, or do I need to post the entire error message?

    Thanks.

  2. #2
    Junior Member
    Join Date
    Apr 2008
    Location
    Alexandria, Virginia
    Posts
    3

    Getting same error

    Hi

    I think I am getting the same error as you. Do your responses look like this?

    #mount --bind /dev /media/sda1/knoppix-tmp/source/KNOPPIX/dev
    mount: wrong fs type, bad option, bad superblock on /dev,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so


    # dmesg | tail
    lo: Disabled Privacy Extensions
    ADDRCONF(NETDEV_UP): eth0: link is not ready
    PCI: Setting latency timer of device 0000:00:02.0 to 64
    [drm] Initialized i915 1.6.0 20060119 on minor 0
    eth1: no IPv6 routers present
    kjournald starting. Commit interval 5 seconds
    EXT3-fs: mounted filesystem with ordered data mode.
    EXT3 FS on sda1, internal journal
    ipw2200: Firmware error detected. Restarting.
    ipw2200: Firmware error detected. Restarting.

  3. #3
    Junior Member registered user
    Join Date
    May 2007
    Location
    Southern California
    Posts
    11

    Re: Getting same error

    Quote Originally Posted by rogerr
    Hi

    I think I am getting the same error as you. Do your responses look like this?

    #mount --bind /dev /media/sda1/knoppix-tmp/source/KNOPPIX/dev
    mount: wrong fs type, bad option, bad superblock on /dev,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so


    # dmesg | tail
    lo: Disabled Privacy Extensions
    ADDRCONF(NETDEV_UP): eth0: link is not ready
    PCI: Setting latency timer of device 0000:00:02.0 to 64
    [drm] Initialized i915 1.6.0 20060119 on minor 0
    eth1: no IPv6 routers present
    kjournald starting. Commit interval 5 seconds
    EXT3-fs: mounted filesystem with ordered data mode.
    EXT3 FS on sda1, internal journal
    ipw2200: Firmware error detected. Restarting.
    ipw2200: Firmware error detected. Restarting.
    Yes, I am getting the same error. The first part you wrote, not the tail data.

    Perhaps what we need to do is try a different volume/partition for the source/master session writes to reside.

  4. #4
    Junior Member
    Join Date
    Apr 2008
    Location
    Alexandria, Virginia
    Posts
    3

    Found this link.

    After 40 google searches I found this link:

    http://www.knoppix.net/wiki/Dev_null_permission_denied

    Hasn't helped my problem. But you may find it useful.

  5. #5
    Junior Member registered user
    Join Date
    May 2007
    Location
    Southern California
    Posts
    11

    Hello??? mount --bind errors?

    Is there no persons out there that have experienced this mount --bind error when remastering the DVD?
    I can't believe that this has not been resolved.

    I also wonder what I did in succeeding to make an 8GB USB drive carry the DVD image and additional apps.

    It was on 5.2 and I cannot remember what I did to get it all onto a USB drive and make it bootable.

    Also... how do I edit the installed application scenario while booted to the USB drive? It makes the partition read only.

  6. #6
    Junior Member
    Join Date
    Apr 2008
    Location
    Alexandria, Virginia
    Posts
    3
    Using the link I posted Friday, I was able to get chroot to work. For whatever reason, I can ignore "mount --bind /dev ..........." .

    Before mounting, it is necessary to make the change to /etc/fstab. Then mounting /proc and /sys seem to be enough for my system.

    Still playing with the configuration. Have not tried to burn the new iso yet.

  7. #7
    Junior Member registered user
    Join Date
    May 2007
    Location
    Southern California
    Posts
    11
    Quote Originally Posted by rogerr
    Using the link I posted Friday, I was able to get chroot to work. For whatever reason, I can ignore "mount --bind /dev ..........." .

    Before mounting, it is necessary to make the change to /etc/fstab. Then mounting /proc and /sys seem to be enough for my system.

    Still playing with the configuration. Have not tried to burn the new iso yet.
    I get a feeling that the way they mount the DVD image as a CD (ISO9660) file system might be the reason. DVDs are UDF, filesystem IIRC. The error is with mount. Perhaps forcing it might work, but I was more interested in someone here knowing what was going on from prior experience. I cannot imagine that I am the first one to see this.

    I suspect that since all the scripts and documents about remastering are about two releases old (at least), that someone (we) need to re-vamp a lot of said documents.

    How hard would the automated script be to make it examine which version of Knoppix is running and branch to the appropriate script segment?

    Somehow, I get the feeling that I will be invited to make such changes. I do not think I have the time or experience, however. It would be more appropriate for one of your gurus to do it.

    Is there a command to test for Knoppix version, or do we parse the uname kernel data to decide?

    I skipped the remaster session so far, and went straight to setting up a 5.3.1 8GB USB drive with SDLMAME on it

    Oh well... enough ranting. Someone(me?) should write a comprehensive script that is so good at setting up remastering that klaus would do a final edit on it and include it on his releases. :-]

Similar Threads

  1. Setting up file servers (5.0.1) - /usr/bin/X11/xauth error?
    By A. Jorge Garcia in forum Hdd Install / Debian / Apt
    Replies: 4
    Last Post: 01-26-2007, 11:56 PM
  2. Ending a session and the next session run
    By holdman in forum General Support
    Replies: 5
    Last Post: 05-18-2006, 08:56 PM
  3. MSI TV Tuner (TV@nywhere Master)??
    By s-r-b in forum Hardware & Booting
    Replies: 0
    Last Post: 10-03-2004, 02:15 AM
  4. Doing a re-master from a CD ?
    By Flying2Eagles in forum Customising & Remastering
    Replies: 5
    Last Post: 11-09-2003, 05:38 PM
  5. Error unmounting drives after re-master.
    By dragonx in forum Customising & Remastering
    Replies: 0
    Last Post: 06-09-2003, 06:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Macintosh Platinum Mouse - Apple 128K 512K 512Ke Mac Plus Lisa IIe M0100 - NEW picture

Macintosh Platinum Mouse - Apple 128K 512K 512Ke Mac Plus Lisa IIe M0100 - NEW

$49.99



1984 APPLE MACINTOSH 128K FIRST MAC Model M0001 PICASSO KIT Discs Harvard Rare picture

1984 APPLE MACINTOSH 128K FIRST MAC Model M0001 PICASSO KIT Discs Harvard Rare

$1800.00



1984 APPLE MACINTOSH 128K MATCHING # BOX Set Original Mac Model M0001 WORKS RARE picture

1984 APPLE MACINTOSH 128K MATCHING # BOX Set Original Mac Model M0001 WORKS RARE

$6299.00



Apple Macintosh 128k Desktop computer. Upgraded to 512k picture

Apple Macintosh 128k Desktop computer. Upgraded to 512k

$300.00



Vintage Apple Macintosh 128K 512K Carrying Case Rainbow Logo Excellent Cond picture

Vintage Apple Macintosh 128K 512K Carrying Case Rainbow Logo Excellent Cond

$140.00



Apple Keyboard and Cable for Macintosh 128k 512k Mac Plus RARE Vintage M0110 picture

Apple Keyboard and Cable for Macintosh 128k 512k Mac Plus RARE Vintage M0110

$129.99



Vintage Early Week 12 1984 Apple Macintosh 128K Computer M0001 w/Analog Board+ picture

Vintage Early Week 12 1984 Apple Macintosh 128K Computer M0001 w/Analog Board+

$209.99



Macintosh Platinum Mouse - Apple 128K 512K 512Ke Mac Plus Lisa IIe M0100 - NEW picture

Macintosh Platinum Mouse - Apple 128K 512K 512Ke Mac Plus Lisa IIe M0100 - NEW

$59.99



Apple Keyboard for Macintosh 128k 512k Mac Plus RARE Vintage M0110 (010) picture

Apple Keyboard for Macintosh 128k 512k Mac Plus RARE Vintage M0110 (010)

$149.00



Apple Macintosh Mac 128k - 512k Boot / Diagnostics 2 Disk Set for Classic Macs picture

Apple Macintosh Mac 128k - 512k Boot / Diagnostics 2 Disk Set for Classic Macs

$14.99