-
Junior Member
registered user
Error setting up re-master session
Hey guys,
I have a re-master session going. I copied all the files over, and upon issuing the bind commands before the chroot, I get an error when binding the /dev directory. It says that the file system is wrong. Is this a familiar error you can help me with, or do I need to post the entire error message?
Thanks.
-
Getting same error
Hi
I think I am getting the same error as you. Do your responses look like this?
#mount --bind /dev /media/sda1/knoppix-tmp/source/KNOPPIX/dev
mount: wrong fs type, bad option, bad superblock on /dev,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so
# dmesg | tail
lo: Disabled Privacy Extensions
ADDRCONF(NETDEV_UP): eth0: link is not ready
PCI: Setting latency timer of device 0000:00:02.0 to 64
[drm] Initialized i915 1.6.0 20060119 on minor 0
eth1: no IPv6 routers present
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
EXT3 FS on sda1, internal journal
ipw2200: Firmware error detected. Restarting.
ipw2200: Firmware error detected. Restarting.
-
Junior Member
registered user
Re: Getting same error

Originally Posted by
rogerr
Hi
I think I am getting the same error as you. Do your responses look like this?
#mount --bind /dev /media/sda1/knoppix-tmp/source/KNOPPIX/dev
mount: wrong fs type, bad option, bad superblock on /dev,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so
# dmesg | tail
lo: Disabled Privacy Extensions
ADDRCONF(NETDEV_UP): eth0: link is not ready
PCI: Setting latency timer of device 0000:00:02.0 to 64
[drm] Initialized i915 1.6.0 20060119 on minor 0
eth1: no IPv6 routers present
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
EXT3 FS on sda1, internal journal
ipw2200: Firmware error detected. Restarting.
ipw2200: Firmware error detected. Restarting.
Yes, I am getting the same error. The first part you wrote, not the tail data.
Perhaps what we need to do is try a different volume/partition for the source/master session writes to reside.
-
Found this link.
After 40 google searches I found this link:
http://www.knoppix.net/wiki/Dev_null_permission_denied
Hasn't helped my problem. But you may find it useful.
-
Junior Member
registered user
Hello??? mount --bind errors?
Is there no persons out there that have experienced this mount --bind error when remastering the DVD?
I can't believe that this has not been resolved.
I also wonder what I did in succeeding to make an 8GB USB drive carry the DVD image and additional apps.
It was on 5.2 and I cannot remember what I did to get it all onto a USB drive and make it bootable.
Also... how do I edit the installed application scenario while booted to the USB drive? It makes the partition read only.
-
Using the link I posted Friday, I was able to get chroot to work. For whatever reason, I can ignore "mount --bind /dev ..........." .
Before mounting, it is necessary to make the change to /etc/fstab. Then mounting /proc and /sys seem to be enough for my system.
Still playing with the configuration. Have not tried to burn the new iso yet.
-
Junior Member
registered user

Originally Posted by
rogerr
Using the link I posted Friday, I was able to get chroot to work. For whatever reason, I can ignore "mount --bind /dev ..........." .
Before mounting, it is necessary to make the change to /etc/fstab. Then mounting /proc and /sys seem to be enough for my system.
Still playing with the configuration. Have not tried to burn the new iso yet.
I get a feeling that the way they mount the DVD image as a CD (ISO9660) file system might be the reason. DVDs are UDF, filesystem IIRC. The error is with mount. Perhaps forcing it might work, but I was more interested in someone here knowing what was going on from prior experience. I cannot imagine that I am the first one to see this.
I suspect that since all the scripts and documents about remastering are about two releases old (at least), that someone (we) need to re-vamp a lot of said documents.
How hard would the automated script be to make it examine which version of Knoppix is running and branch to the appropriate script segment?
Somehow, I get the feeling that I will be invited to make such changes. I do not think I have the time or experience, however. It would be more appropriate for one of your gurus to do it.
Is there a command to test for Knoppix version, or do we parse the uname kernel data to decide?
I skipped the remaster session so far, and went straight to setting up a 5.3.1 8GB USB drive with SDLMAME on it
Oh well... enough ranting. Someone(me?) should write a comprehensive script that is so good at setting up remastering that klaus would do a final edit on it and include it on his releases. :-]
Similar Threads
-
By A. Jorge Garcia in forum Hdd Install / Debian / Apt
Replies: 4
Last Post: 01-26-2007, 11:56 PM
-
By holdman in forum General Support
Replies: 5
Last Post: 05-18-2006, 08:56 PM
-
By s-r-b in forum Hardware & Booting
Replies: 0
Last Post: 10-03-2004, 02:15 AM
-
By Flying2Eagles in forum Customising & Remastering
Replies: 5
Last Post: 11-09-2003, 05:38 PM
-
By dragonx in forum Customising & Remastering
Replies: 0
Last Post: 06-09-2003, 06:25 AM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

Gigabyte 4U AI Server 10x Nvidia GPU 2x Xeon Gold 6150 36 Core 2.7GHz DDR4 RAM
$1499.00

Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD
$275.00

867959-B21 HPE ProLiant DL360 G10 CTO Server W/ 2x 865414-B21 1x 840140-001
$245.00

Dell PowerEdge R530 2x E5-2630v4 H330 iDRAC8 Port Card Riser No PSU/RAM/HDD
$99.99

Dell Poweredge R730xd 12LFF 2*2660v4 4*1Gbe h730 2x 750W Server CTO
$308.00

Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2690 v3 | 64gb Ram | 2x 1600W
$524.99

Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W
$409.99

128GB (4x32GB) SK hynix DDR4 PC4-2666V RDIMM ECC Server Ram HMA84GR7CJR4N-VK
$799.00

Dell PowerEdge FX2s + 8x FC430 Blades 16x E5-2630v4 160 Cores Rails No PSU/RAM
$699.00

Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Core | HBA330 | No RAM or HDD
$149.99