Results 1 to 3 of 3

Thread: Su returned with an error

  1. #1
    Junior Member
    Join Date
    Oct 2008
    Location
    northern Scotland UK
    Posts
    2

    Su returned with an error

    Having successfully installed Knoppix 5.1.1 (following a download and subsequent ISO burn) on the 20GB HDD of a P3 laptop with max 256MB RAM ,each time I try to access services in KDE requiring the root password , for example when wishing to change the area time or any other services , the response is : Su returned with error.

    This is my first encounter with a debian fork after having used the Mandriva distro.

    Does someone know what the problem is and how to correct ?

    TIA for any advice

    Frank higlandham

  2. #2
    Junior Member
    Join Date
    Nov 2008
    Location
    UK
    Posts
    7
    I had similar problems a couple of weeks ago.
    Have you set root password. (Penguin/set root password)?
    David

  3. #3
    Junior Member
    Join Date
    Oct 2008
    Location
    northern Scotland UK
    Posts
    2
    I have sollved the 'su in KDE' problem following advice from this forum , now realising that the problem already had been posted by someone else.

    From / home/frank I selected hidden file and found /.kde ---> / share ---> / config ----> /config ----> / kdesurc

    Opened kdesurc with Kwrite and made the following change : super-user-command=sudo to super-user-command=su

    saved kdesurc and closed Kwrite

    I now can access all progs requiring root password from within KDE


    Frank (highlandham) temporarily in Torrance - California

Similar Threads

  1. " Su returned with an error " in KDE [SOLVED]
    By JediatNight in forum Hdd Install / Debian / Apt
    Replies: 26
    Last Post: 05-18-2009, 06:10 PM
  2. Here is how I fixed 'su returned error' in KDE
    By madman34 in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 04-20-2007, 08:06 AM
  3. SU Returned with ERROR in Root Shell
    By Student in forum Hdd Install / Debian / Apt
    Replies: 5
    Last Post: 04-07-2007, 07:44 AM
  4. E: Sub-process /usr/bin/dpkg returned an error code (1)
    By OP4Latino in forum General Support
    Replies: 1
    Last Post: 07-19-2005, 05:00 AM
  5. apt-get problem "returned an error code (1)"
    By migross in forum General Support
    Replies: 4
    Last Post: 10-23-2003, 07:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5

Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5" 512e HDD NetApp X375A

$64.00



Seagate ST8000NM0075 Enterprise Capacity 3.5 HDD 8TB SAS Hard Drive 8TB EXOS picture

Seagate ST8000NM0075 Enterprise Capacity 3.5 HDD 8TB SAS Hard Drive 8TB EXOS

$184.99



DELL 2TB Enterprise HDD (7200RPM, 3.5

DELL 2TB Enterprise HDD (7200RPM, 3.5", SATA III, 128MB Cache) HUS722T2TALA600

$49.95



HDD 3.5

HDD 3.5" SATA Hard Drive with Windows 10/Win 11 64x Installed Legacy

$35.00



Dell ST6000NM0034 1HT27Z-150 NWCCG 6TB SAS 3.5 7.2K ENTERPRISE SERVER DRIVE picture

Dell ST6000NM0034 1HT27Z-150 NWCCG 6TB SAS 3.5 7.2K ENTERPRISE SERVER DRIVE

$68.99



Hitachi Ultrastar 3TB 7200RPM 3.5in SATA III 6Gb/s - enterprise-grade hard drive picture

Hitachi Ultrastar 3TB 7200RPM 3.5in SATA III 6Gb/s - enterprise-grade hard drive

$49.00



Seagate ST3000NM0005 HDD 3TB SATA 6Gb/s 7.2K 3.5

Seagate ST3000NM0005 HDD 3TB SATA 6Gb/s 7.2K 3.5" 512 b/s

$59.00



Western Digital Blue (7200RPM, 3.5

Western Digital Blue (7200RPM, 3.5", SATA III, 64MB Cache) 1TB HDD

$19.90



HUS726060ALA640 HGST Ultrastar  6TB SATA 6Gbps 7.2K 3.5

HUS726060ALA640 HGST Ultrastar 6TB SATA 6Gbps 7.2K 3.5" Hard Drive OF21860

$129.99



Western Digital 1TB 3.5

Western Digital 1TB 3.5" SATA III 7200RPM Desktop Hard Drive

$34.99