Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: creating the iso image...

  1. #11
    Senior Member registered user
    Join Date
    Dec 2009
    Posts
    423
    If you are running this on a KNOPPIX system, I would like to believe that you will have these :-
    Code:
    $ ls -al /dev/cloop*
    lrwxrwxrwx 1 root root      6 2010-08-30 23:14 /dev/cloop -> cloop0
    brw-rw---- 1 root disk 240, 0 2010-08-30 23:14 /dev/cloop0
    brw-rw---- 1 root disk 240, 1 2010-08-30 23:14 /dev/cloop1
    brw-rw---- 1 root disk 240, 2 2010-08-30 23:14 /dev/cloop2
    brw-rw---- 1 root disk 240, 3 2010-08-30 23:14 /dev/cloop3
    brw-rw---- 1 root disk 240, 4 2010-08-30 23:14 /dev/cloop4
    brw-rw---- 1 root disk 240, 5 2010-08-30 23:14 /dev/cloop5
    brw-rw---- 1 root disk 240, 6 2010-08-30 23:14 /dev/cloop6
    brw-rw---- 1 root disk 240, 7 2010-08-30 23:14 /dev/cloop7
    For whatever reasons if you don't have them, then you manually create them :-

    # mknod /dev/cloop1 b 240 1

    You shouldn't be using /dev/cloop or /dev/cloop0 because that's already been used by KNOPPIX.

    Yes, if the image is good, you shouldn't get any errors when you loop mount your new compressed image. But I still would like to believe that chances of a bad burn is higher. You should do a 'knoppix testcd'.

    Cheers

  2. #12
    Junior Member
    Join Date
    Aug 2010
    Posts
    8
    kl522, I appreciate your help with this. I get the same results you show with the ls command. My point was I know cloop1 is there but for whatever reason I get errors on the ioctl so I was checking if it was already being used. The first unused cloop is cloop1, as I'm sure you suspected, but it's not working.

    I tried the bootfrom=<iso path> but that just booted directly from the knoppix live cd for some reason and didn't verify the iso.

    booting with testcd gives me the following:

    All files OK.

    >>> Starting in Live-Mode. <<<
    >>> Please do not remove medium until shutdown! <<<
    /init: line 693: /bin/mount: Input/output error
    /init: exec: line 742: /sbin/init: Input/output error


    from here it just hangs indefinitely. This has happened on the last two images I've built and burned.

    I tried to find the /init file but can't seem to view it anywhere in my "master" file structure.

  3. #13
    Senior Member registered user
    Join Date
    Dec 2009
    Posts
    423
    Quote Originally Posted by frankp View Post
    the losetup command gives me a "bad file descriptor" error...

    ioctl: LOOP_SET_FD: Bad file descriptor
    Yes, it shows that you have a bad compressed image to start with.
    I simply take a normal file and do a losetup on it, I get the same error :-

    Code:
              # cd /tmp
              # cp /etc/hosts hosts
              # losetup -r /dev/cloop1 hosts
    ioctl: LOOP_SET_FD: Bad file descriptor
    This happens when I run this command from the / directory. If I run it from anywhere else, I get KNOPPIX: No such file or directory
    You must path the command to the right directory/file, eg :-
    # losetup -r /dev/cloop1 /some_path_some_where/knx/master/KNOPPIX/KNOPPIX

    I find it strange that your working copy of KNOPPIX is resided in /KNOPPIX. In any case, you have to know what it resides, and substitute the correct path for it.

    But whatever it is, if you have issued the command pointing to the correct KNOPPIX compressed image, the conclusion is that you have an invalid compressed image. You back to review your steps again.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


5 Port Gigabit Unmanaged Ethernet Switch, Home Network Hub, Office Ethernet S... picture

5 Port Gigabit Unmanaged Ethernet Switch, Home Network Hub, Office Ethernet S...

$9.64



NETGEAR GS308EP Essential Series 8-Port Gigabit PoE+ Unmanaged Switch picture

NETGEAR GS308EP Essential Series 8-Port Gigabit PoE+ Unmanaged Switch

$49.99



TP-Link TL-SG1048 48-Port Gigabit Rackmount Switch New Factory Sealed picture

TP-Link TL-SG1048 48-Port Gigabit Rackmount Switch New Factory Sealed

$199.99



Cisco Catalyst 2960-48TT-L 48-Port Fast Ethernet Managed Rackmount Switch picture

Cisco Catalyst 2960-48TT-L 48-Port Fast Ethernet Managed Rackmount Switch

$46.99



TP-Link TL-SG105 5-Port Gigabit Ethernet Unmanaged Metal Desktop Network Switch picture

TP-Link TL-SG105 5-Port Gigabit Ethernet Unmanaged Metal Desktop Network Switch

$19.99



10-Port Gigabit PoE Network Switch with 8 PoE+ Ports with 2 Combo SFP Slots 125W picture

10-Port Gigabit PoE Network Switch with 8 PoE+ Ports with 2 Combo SFP Slots 125W

$39.99



TP-Link TL-SG105, 5 Port Gigabit Unmanaged Ethernet Switch, Network Hub, Ethern picture

TP-Link TL-SG105, 5 Port Gigabit Unmanaged Ethernet Switch, Network Hub, Ethern

$15.25



Arista DCS-7010T-48-R 48P 1GbE 4P 10GbE SFP+ RA Switch with rack mounts picture

Arista DCS-7010T-48-R 48P 1GbE 4P 10GbE SFP+ RA Switch with rack mounts

$69.00



D-Link DGS-1210-28P 28-Port PoE Gigabit Web Smart Switch With Cord picture

D-Link DGS-1210-28P 28-Port PoE Gigabit Web Smart Switch With Cord

$49.99



HP ProCurve J9265A 6600-24XG 10GBE Layer3 Gigabit Switch w/ 2 x PSU picture

HP ProCurve J9265A 6600-24XG 10GBE Layer3 Gigabit Switch w/ 2 x PSU

$180.20