Quote Originally Posted by frankp View Post
the losetup command gives me a "bad file descriptor" error...

ioctl: LOOP_SET_FD: Bad file descriptor
Yes, it shows that you have a bad compressed image to start with.
I simply take a normal file and do a losetup on it, I get the same error :-

Code:
          # cd /tmp
          # cp /etc/hosts hosts
          # losetup -r /dev/cloop1 hosts
ioctl: LOOP_SET_FD: Bad file descriptor
This happens when I run this command from the / directory. If I run it from anywhere else, I get KNOPPIX: No such file or directory
You must path the command to the right directory/file, eg :-
# losetup -r /dev/cloop1 /some_path_some_where/knx/master/KNOPPIX/KNOPPIX

I find it strange that your working copy of KNOPPIX is resided in /KNOPPIX. In any case, you have to know what it resides, and substitute the correct path for it.

But whatever it is, if you have issued the command pointing to the correct KNOPPIX compressed image, the conclusion is that you have an invalid compressed image. You back to review your steps again.