Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: creating the iso image...

  1. #11
    Senior Member registered user
    Join Date
    Dec 2009
    Posts
    423
    If you are running this on a KNOPPIX system, I would like to believe that you will have these :-
    Code:
    $ ls -al /dev/cloop*
    lrwxrwxrwx 1 root root      6 2010-08-30 23:14 /dev/cloop -> cloop0
    brw-rw---- 1 root disk 240, 0 2010-08-30 23:14 /dev/cloop0
    brw-rw---- 1 root disk 240, 1 2010-08-30 23:14 /dev/cloop1
    brw-rw---- 1 root disk 240, 2 2010-08-30 23:14 /dev/cloop2
    brw-rw---- 1 root disk 240, 3 2010-08-30 23:14 /dev/cloop3
    brw-rw---- 1 root disk 240, 4 2010-08-30 23:14 /dev/cloop4
    brw-rw---- 1 root disk 240, 5 2010-08-30 23:14 /dev/cloop5
    brw-rw---- 1 root disk 240, 6 2010-08-30 23:14 /dev/cloop6
    brw-rw---- 1 root disk 240, 7 2010-08-30 23:14 /dev/cloop7
    For whatever reasons if you don't have them, then you manually create them :-

    # mknod /dev/cloop1 b 240 1

    You shouldn't be using /dev/cloop or /dev/cloop0 because that's already been used by KNOPPIX.

    Yes, if the image is good, you shouldn't get any errors when you loop mount your new compressed image. But I still would like to believe that chances of a bad burn is higher. You should do a 'knoppix testcd'.

    Cheers

  2. #12
    Junior Member
    Join Date
    Aug 2010
    Posts
    8
    kl522, I appreciate your help with this. I get the same results you show with the ls command. My point was I know cloop1 is there but for whatever reason I get errors on the ioctl so I was checking if it was already being used. The first unused cloop is cloop1, as I'm sure you suspected, but it's not working.

    I tried the bootfrom=<iso path> but that just booted directly from the knoppix live cd for some reason and didn't verify the iso.

    booting with testcd gives me the following:

    All files OK.

    >>> Starting in Live-Mode. <<<
    >>> Please do not remove medium until shutdown! <<<
    /init: line 693: /bin/mount: Input/output error
    /init: exec: line 742: /sbin/init: Input/output error


    from here it just hangs indefinitely. This has happened on the last two images I've built and burned.

    I tried to find the /init file but can't seem to view it anywhere in my "master" file structure.

  3. #13
    Senior Member registered user
    Join Date
    Dec 2009
    Posts
    423
    Quote Originally Posted by frankp View Post
    the losetup command gives me a "bad file descriptor" error...

    ioctl: LOOP_SET_FD: Bad file descriptor
    Yes, it shows that you have a bad compressed image to start with.
    I simply take a normal file and do a losetup on it, I get the same error :-

    Code:
              # cd /tmp
              # cp /etc/hosts hosts
              # losetup -r /dev/cloop1 hosts
    ioctl: LOOP_SET_FD: Bad file descriptor
    This happens when I run this command from the / directory. If I run it from anywhere else, I get KNOPPIX: No such file or directory
    You must path the command to the right directory/file, eg :-
    # losetup -r /dev/cloop1 /some_path_some_where/knx/master/KNOPPIX/KNOPPIX

    I find it strange that your working copy of KNOPPIX is resided in /KNOPPIX. In any case, you have to know what it resides, and substitute the correct path for it.

    But whatever it is, if you have issued the command pointing to the correct KNOPPIX compressed image, the conclusion is that you have an invalid compressed image. You back to review your steps again.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


IBM System X3850-X5 Server w/4x Intel  Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD picture

IBM System X3850-X5 Server w/4x Intel Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD

$1299.99



IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5

IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM

$149.99



IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon  E5620 picture

IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon E5620

$199.99



Lot of 2 IBM blade center Type H chassis 8852 picture

Lot of 2 IBM blade center Type H chassis 8852

$559.00



IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES picture

IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES

$108.92



IBM SERVER SLED WITH HDD SCSI 8.8GB ,P005043441, AS IS,UNTESTED picture

IBM SERVER SLED WITH HDD SCSI 8.8GB ,P005043441, AS IS,UNTESTED

$165.00



IBM Power S824 12Bay 4U Server - 2x Power8 CPU, 512GB DDR4, MT: 8286-42A picture

IBM Power S824 12Bay 4U Server - 2x Power8 CPU, 512GB DDR4, MT: 8286-42A

$1731.00



IBM 02YC027 Seagate ST2400MM0129 2.4TB 10K SAS 12Gb/s 2.5

IBM 02YC027 Seagate ST2400MM0129 2.4TB 10K SAS 12Gb/s 2.5" Server Hard Drive

$200.00



Unused IBM 09P0037 MAINBOARD For  RS/6000 7044-170 P-Series picture

Unused IBM 09P0037 MAINBOARD For RS/6000 7044-170 P-Series

$375.00



IBM 7915 AC1 M4 E27R704 Server Intel 2650V2 32GB RAM NO HDD w/ 2x 750w PSU picture

IBM 7915 AC1 M4 E27R704 Server Intel 2650V2 32GB RAM NO HDD w/ 2x 750w PSU

$250.00