Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Floppy Icon missing from Desktop

  1. #11
    Senior Member registered user
    Join Date
    May 2006
    Columbia, Maryland USA

    Nicely done, sir.

    If these last steps work out, shouldn't the patient
    modify his /etc/fstab accordingly?

    I note that in some earlier versions of Knoppix, there used to
    be an entry in /etc/fstab of the form:
    /dev/fd0 /floppy auto defaults,user,noauto 0 0
    or, using your terminology,
    /dev/fd0 /media/fd0...etc.

    If Knoppix 6.4.3 doesn't mount floppies automatically,
    then hopefully we can click File Manager to mount fd0.
    If not, we may still need a clickable icon on the desktop,
    in addition to the mkdir and fstab additions here.

    For what it's worth, when I plug in my USB floppy,
    Knoppix 6.4.3 adds the following to my /etc/fstab, and
    vfat stuff shows up in File manager to be read, etc:

    # Added by KNOPPIX
    /dev/sdc /media/sdc vfat noauto,users,exec,umask=000,shortname=winnt,uid=kn oppix,gid=knoppix 0 0

    I have a usb floppy to read some old stuff of mine.
    Would you believe GWBasic?

    You are in good hands. These guys, and Harry know
    Knoppix inside out.

  2. #12
    Junior Member
    Join Date
    Jan 2011
    The command Code: hwinfo --floppy Did not show anything. I did see the screen flash something but only the command prompt returned.
    Code: sudo mkdir /media/fd0 and sudo mount -o uid=1000,gid=1000 /dev/fd0 /media/fd0 also did not have any affect. Still no Floppy icon anywhere.
    I opened File Manager clicked GO then My Computer and in the right pane there was the Floppy icon. A single click on any of these I get: Error File Doesn't exist. A Right-click shows Open or Properties, Open gets File Doesn't exixt, Properties shows File Type of Mount Point, Size of files 0 last access 01/01/70 00:00.
    I then opened Leaf Pad and clicked Open, the device list showed Floppy Drive but no Files.
    I Shutdown the MSI system and tried my old ECS system. First thing I noticed is that Linux Kernel took less than a second. On the MSI system it took 65 seconds. Still no Floppy icon and File manager acted the same. But with Leaf Pad I was able to Open and Save TXT files.
    I think the BIOS on the MSI system is bad. I will stick with DOS and Windows to do the rest of my tests.
    Someone more familiar with Linux should look into the Floppy issues as there is something wrong with the whole Knoppix File Manager thing.

    Unless someone is willing to "show" me how to Run a DOS/Windows executable from a Jumpdrive, then this thread is closed.


  3. #13
    Senior Member registered user
    Join Date
    May 2006
    Columbia, Maryland USA

    I have NO fd on my system.
    cd /var/log..........................................'set up shop in /var/log
    rm user.log........................................ 'erase user.log
    hwinfo --floppy --log user.log.............. 'generates a 600k text file in user.log

    less user.log | grep fd......................... 'doesn't tell me anything useful about anything fd...
    less user.log | grep floppy................... 'nor does this

    Just watching the lxterminal, this 600k of text
    flies by on one line in about 1 or 2 sec.

    I have a cdrw.
    Doing a similar exercise as above,

    rm user.log
    hwinfo --cdrom --log user.log ..............'generates a text file almost as big as for floppy

    less less user.log | grep cd................... 'tells me a lot about cd... things

    As before,
    Just watching the lxterminal, this 600k of text
    flies by on one line in about 1 or 2 sec.
    Last edited by utu; 01-22-2011 at 12:12 AM.

  4. #14
    Senior Member registered user
    Join Date
    Feb 2010
    Today I booted Knoppix 6.4.3 CD on my notebook (HP omnibook xt1000) with a USB floppy disk drive connected. There was no medium in the floppy drive. I issued hwinfo --floppy in a terminal and was surprised that the the command did not show any information about the floppy disk drive. I issued
    hwinfo --usb
    and found a long list of USB devices. One device was my USB floppy disk drive. It had got the device name /dev/sdb.

    My next step was to open the PCMan Filemanager. I did not see any icon for the floppy disk drive. After I had inserted a floppy disk into the floppy disk drive there was activity in the floppy disk drive and in the PCMan Filemanager's left pane appeared a new icon. It had got the same name as the floppy disk. I clicked on that icon and in the PCMan Filemanager's right pane appeared the usual icons. The floppy disk's mount point was /media/sdb. When I removed the floppy disk from the drive the icons disappeared in the right pane of the file manager. In the left pane of the PCMan Filemanager vanished the floppy disk's icon.

    After this success I took my Windows 7 Pro system with Oracle VirtualBox 3.2.12 installed. This system has got a traditional floppy disk drive built in. I had to add a floppy disk drive to my virtual maschine before I started Knoppix 6.4.3. I opened a terminal and issued hwinfo --floppy. Again there was no information about the floppy disk drive. But when I issued
    hwinfo --storage-ctrl
    I saw that there was floppy disk controller in the system. Afterwards I opened the PCMan Filemanager and inserted a floppy disk into the physical floppy disk drive. There was no icon for the floppy disk shown in the filemanager's window. Therefore I issued the commands I suggested in my previous post.
    sudo mkdir /media/fd0
    sudo mount -o uid=1000,gid=1000 /dev/fd0 /media/fd0
    This time there was no special icon for the floppy disk drive but after I had moved to the directory /media/fd0 I found the files on the floppy disk. I closed the filemanager's window and issued
    sudo umount /media/fd0
    before I removed the floppy disk from the floppy disk drive.

    My third attempt was to boot my PC from the Knoppix 6.4.3 CD. There was a similar experience as in the virtual maschine. But I after had plugged in my USB floppy disk drive the floppy disk was detected automatically as in the first attempt with the notebook.

    Maybe there is a way to turn on an automount operation for the traditional floppy disk drives in Knoppix 6.4.3. But in the rare case that I need a floppy disk drive I can use my USB device.

  5. #15
    Senior Member registered user
    Join Date
    May 2006
    Columbia, Maryland USA
    I think this mystery may be just one of expectations.

    I note there is no icon for a CD initially anywhere
    on my Desktop or File Manager UNTIL there is some
    removable medium actually in the CD device.

    Usually Knoppix prompts for some information if it
    sees a new device or new media. Soon afterwards
    appropriate icons appear here and there in the
    File Manager.

    Wouldn't surprise me (NOW) if that's true for floppies and
    USB devices as well.

  6. #16
    Moderator Moderator
    Join Date
    Jan 2010
    Asheville, NC, USA
    Since a mount command is required for most filesystems, I'm not surprised that the drive doesn't show up in pcman unless there's a medium in a removable type drive. The raw, unmounted "drive" (filesystem) shows up as soon as I plug something in, but I have to click it in the list of filesystems to mount it. I haven't seen drive icons on the desktop since version 5, either before or after mounting.


Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts