Results 1 to 3 of 3

Thread: PXE booting knoppix 6.4.4 no cloop module...

  1. #1
    Junior Member
    Join Date
    Apr 2011

    PXE booting knoppix 6.4.4 no cloop module...

    Hello -

    The 6.4.4 image that I downloaded from does not contain the cloop.ko and aufs.ko modules that are required to be able to pxe boot. Copying in the modules from a previous version seems to work fine, but is there a reason these are left out of the iso?



  2. #2
    Senior Member
    Join Date
    Jan 2011
    Hi mdcoffman and welcome to the Knoppix forums.

    This is a curious one. You are not going to believe me but never mind.

    The cloop.ko and aufs.ko are built into the kernel so while you won't find them they are there.

    I've had Knoppix 6.4.4. PXE boot work (to my astonishment). It worked first time and all I did was start the Knoppix terminal server. I did not have to copy modules from anywhere to anywhere else.

    Linux kernel modules are complied to run with a particular kernel. Modules from a 'previous' version of Knoppix just will not load into a different 'newer' version. It's a sanity thing.

    Somewhere I think you have become confused.

    See, I told you you wouldn't believe me.

  3. #3
    Junior Member
    Join Date
    Apr 2011
    You're correct, I became confused. I had used the miniroot and the linux kernel on the CD and not the ones that get created on a system running Knoppix when the terminal server is started. I booted from a CD, started the terminal server, then copied the goodies out of /tftpboot and it works now. Thanks for taking the time reply to my question.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts