-
Unable to mount MacBook HD in Knoppix 6.4.4
I'm trying to recover data from the internal HD of a MacBook, which has recently stopped booting to its native OS (OSX 10.4.11). When I enter
Code:
mount -t hfsplus /dev/sda2 /mnt/sda2
in LXTerminal, it returns:
Code:
mount: special device /dev/sda2 does not exist
Strangely (at least to me), when I run
and enter the "print" command, I get (usually after several minutes):
Code:
Model: ATA Hitachi HTS54161 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Number Start End Size File system Name Flags
1 20.5kB 210MB 210MB fat32 EFI system partition boot
2 210MB 120GB 120GB Customer
I was able to mount an external HD with an HFS+ partition (where I would like to copy the files from the internal drive) without issue.
Is there any reason that parted would be able to find /dev/sda, but not mount?
One possible solution I thought about was to write a new partition table (not GPT) to the internal drive that would be readable in mount, but I don't want to try that without some guidance for obvious reasons.
Any help would be greatly appreciated!
More info:
Code:
root@Microknoppix:/home/knoppix# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:07.0 Performance counters: Intel Corporation Device 27a3 (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 22)
02:00.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)
03:03.0 FireWire (IEEE 1394): Agere Systems FW322/323 (rev 61)
Code:
root@Microknoppix:/home/knoppix# dmesg | grep sda
[51840.398745] sd 2:0:1:0: [sda] Unhandled sense code
[51840.398750] sd 2:0:1:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[51840.398758] sd 2:0:1:0: [sda] Sense Key : Medium Error [current] [descriptor]
[51840.398800] sd 2:0:1:0: [sda] Add. Sense: Unrecovered read error - auto reallocate failed
[51840.398812] sd 2:0:1:0: [sda] CDB: Read(10): 28 00 00 06 40 28 00 00 08 00
[51840.398830] end_request: I/O error, dev sda, sector 409642
[51840.398837] Buffer I/O error on device sda, logical block 51205
[51864.365452] sd 2:0:1:0: [sda] Unhandled sense code
[51864.365457] sd 2:0:1:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[51864.365465] sd 2:0:1:0: [sda] Sense Key : Medium Error [current] [descriptor]
[51864.365517] sd 2:0:1:0: [sda] Add. Sense: Unrecovered read error - auto reallocate failed
[51864.365526] sd 2:0:1:0: [sda] CDB: Read(10): 28 00 00 06 40 28 00 00 08 00
[51864.365539] end_request: I/O error, dev sda, sector 409642
[51864.365545] Buffer I/O error on device sda, logical block 51205
[51888.288727] sd 2:0:1:0: [sda] Unhandled sense code
[51888.288732] sd 2:0:1:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[51888.288739] sd 2:0:1:0: [sda] Sense Key : Medium Error [current] [descriptor]
[51888.288781] sd 2:0:1:0: [sda] Add. Sense: Unrecovered read error - auto reallocate failed
[51888.288793] sd 2:0:1:0: [sda] CDB: Read(10): 28 00 00 06 40 28 00 00 08 00
[51888.288812] end_request: I/O error, dev sda, sector 409642
[51888.288819] Buffer I/O error on device sda, logical block 51205
[51912.168754] sd 2:0:1:0: [sda] Unhandled sense code
[51912.168759] sd 2:0:1:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[51912.168766] sd 2:0:1:0: [sda] Sense Key : Medium Error [current] [descriptor]
[51912.168809] sd 2:0:1:0: [sda] Add. Sense: Unrecovered read error - auto reallocate failed
[51912.168821] sd 2:0:1:0: [sda] CDB: Read(10): 28 00 00 06 40 28 00 00 08 00
[51912.168848] end_request: I/O error, dev sda, sector 409642
[51912.168853] Buffer I/O error on device sda, logical block 51205
[51936.212041] sd 2:0:1:0: [sda] Unhandled sense code
[51936.212046] sd 2:0:1:0: [sda] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[51936.212054] sd 2:0:1:0: [sda] Sense Key : Medium Error [current] [descriptor]
[51936.212096] sd 2:0:1:0: [sda] Add. Sense: Unrecovered read error - auto reallocate failed
[51936.212108] sd 2:0:1:0: [sda] CDB: Read(10): 28 00 00 06 40 28 00 00 08 00
[51936.212126] end_request: I/O error, dev sda, sector 409642
[51936.212133] Buffer I/O error on device sda, logical block 51205
-
Possible solution
Hi Ryan,
I was tumbling around the web with the same issue as you and I think I found a solution. Two things have to be done:
- Enable kernel modules:
Code:
# modprobe hfs
# modprobe hfsplus
(Don’t know if this has to be done in order, but I guess it won’t hurt if you do so). - Repopulate filesystem (credit: http://www.renanmarks.net/en/blog/re...g-linux-system ). Knoppix has parted, which AFAIK comes with a program called partprobe. Execute it now that it will recognize HFS partitions and then there you will find new directories under /media:
Code:
# partprobe /dev/sdb
(assuming that the HFS partition is in /dev/sdb).
Note: If you have a HFS+ partition (journal enabled) it will probably mount it in read-only mode. You can fix this by mounting the partition with the force option:
Code:
# mount -o force,rw /media/sdb2
(again, assuming /dev/sdb2 is the HFS partition).
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

Gigabyte 4U AI Server 10x Nvidia GPU 2x Xeon Gold 6150 36 Core 2.7GHz DDR4 RAM
$1625.00

Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD
$275.00

Microsoft Windows Server 2025 Standard 64Bit 16 Core-50 CALs DVD With Key Sealed
$49.99

VMware vCenter Server 8 STANDARD Perpetual License Key VC-STD-C (Legacy Pack)
$1599.95

Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W
$409.99

Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p
$499.88

HPE ProLiant DL380 Gen10 2x Xeon Gold 6132 296GB DDR4 2U Server No HDD.
$1129.99

Dell PowerEdge R730XD 28 Core Server 2X Xeon E5-2680 V4 H730 32GB RAM No HDD
$378.93

867959-B21 HPE ProLiant DL360 G10 CTO Server W/ 2x 865414-B21 1x 840140-001
$245.00

Dell EMC VxRail E560F 10-SFF 2*Gold 6230R 2.1GHz No RAM HBA330 iDrac Ent Server
$349.99