Results 1 to 3 of 3

Thread: problem with package

  1. #1
    Member registered user
    Join Date
    May 2009
    Posts
    32

    problem with package

    hi i try to install pidgin-ppa on knoppix hd install

    but something gone wrong and now i get this error:


    Removing pidgin-ppa ...
    gpg: key "67265EB522BDD6B1C69E66ED7FB8BEE0A1F196A8" not found: eof
    gpg: 67265EB522BDD6B1C69E66ED7FB8BEE0A1F196A8: delete key failed: eof
    dpkg: error processing pidgin-ppa (--remove):
    subprocess installed post-removal script returned error exit status 2
    Errors were encountered while processing:
    pidgin-ppa
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    and now i am unable to use package installer because of this error

    what can i do to fix the error?

    thanks best regards

  2. #2
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    511
    I think that the package pidgin-ppa is made for Ubuntu but not for Debian.

    To remove the package open a terminal and load the post removal script file in an editor.
    Code:
    sudo leafpad /var/lib/dpkg/info/pidgin-ppa.postrm
    The idea is to mark the command line producing the error message as a comment.

    The post removal script has got a line "apt-key del ..." which I commented out.
    Code:
    !/bin/sh -e
    # vim: ai ts=4 sts=4 et sw=4
    
    if [ "$1" = "remove" ]; then
    #    apt-key del 67265EB522BDD6B1C69E66ED7FB8BEE0A1F196A8
        rm -f /etc/apt/sources.list.d/pidgin-ppa.list
    fi
    
    # Automatically added by dh_installinit
    if [ "$1" = "purge" ] ; then
            update-rc.d pidgin-ppa remove >/dev/null
    fi
    # End automatically added section
    # Automatically added by dh_installdebconf
    if [ "$1" = purge ] && [ -e /usr/share/debconf/confmodule ]; then
            . /usr/share/debconf/confmodule
            db_purge
    fi
    # End automatically added section
    Save the file and exit the editor.

    Issue the following commands in the terminal.
    Code:
    sudo dpkg -l pidgin-ppa
    sudo dpkg --purge pidgin-ppa
    sudo dpkg -l pidgin-ppa
    The last command should show that the package is not installed anymore.

    You can find a package of pidgin in the Debian testing (Wheezy) software repository.

    I hope that helps.

  3. #3
    Member registered user
    Join Date
    May 2009
    Posts
    32
    yes it worked
    editing /var/lib/dpkg/info/pidgin-ppa.postrm
    and commenting
    apt-key del 67265EB522BDD6B1C69E66ED7FB8BEE0A1F196A8
    worked fine

    thank you very much ))
    it was my fault: i try to install ubuntu package on debian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •