Results 1 to 7 of 7

Thread: problems after apt-get -dist-upgrade -f

  1. #1
    Member registered user
    Join Date
    May 2009
    Posts
    32

    problems after apt-get -dist-upgrade -f

    hi
    i use knoppix 6.2 hd installed

    i used command
    apt-get -dist-upgrade -f

    but it ended with "error processing ppp_xx.xx.x.deb" (i don't remember exact name it begins with ppp and followed by version numbers )
    and after that network does not work any more , network monitor applet does not appear
    and i am unable to set up network connection
    next in the system settings there is no way to set up keyboard layout any more.
    perhaps there are other things broken after apt-get -dist-upgrade -f ...
    what i can do to make system working again ?

    thanks best regards

  2. #2
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    511
    I would change to a console and change to runlevel 2 with the command
    Code:
    init 2
    The next step would be
    Code:
    dpkg --configure -a
    This will give some error message about packages which could not be installed properly.

    You can switch back to runlevel 5 by issuing
    Code:
    init 5

  3. #3
    Member registered user
    Join Date
    May 2009
    Posts
    32
    here the errors : root@Microknoppix:/home/knoppix# apt-get install -f ....... Preparing to replace ppp 2.4.4rel-10.1 (using .../archives/ppp_2.4.5-4_i386.deb) ... Unpacking replacement ppp ... dpkg: error processing /var/cache/apt/archives/ppp_2.4.5-4_i386.deb (--unpack): trying to overwrite '/etc/chatscripts/gprs', which is also in package ppp-scripts-knoppix 0.6-2 configured to not write apport reports Processing triggers for man-db ... Errors were encountered while processing: /var/cache/apt/archives/ppp_2.4.5-4_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1) root@Microknoppix:/home/knoppix# dpkg --configure -a dpkg: dependency problems prevent configuration of network-manager-pptp: network-manager-pptp depends on ppp (>= 2.4.5); however: Version of ppp on system is 2.4.4rel-10.1. dpkg: error processing network-manager-pptp (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of network-manager-pptp-gnome: network-manager-pptp-gnome depends on network-manager-pptp (= 0.8.1-1); however: Package network-manager-pptp is not configured yet. dpkg: error processing network-manager-pptp-gnome (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of wvdial: wvdial depends on libuniconf4.6; however: Package libuniconf4.6 is not installed. dpkg: error processing wvdial (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: network-manager-pptp network-manager-pptp-gnome wvdial i hope to recover my knoppix thanks best regards

  4. #4
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    511
    dpkg: error processing /var/cache/apt/archives/ppp_2.4.5-4_i386.deb (--unpack): trying to overwrite '/etc/chatscripts/gprs', which is also in package ppp-scripts-knoppix 0.6-2 configured to not write apport reports
    I would suggest to make a backup copy of /etc/chatscripts/gprs and to issue
    Code:
    dpkg -i --force-overwrite /var/cache/apt/archives/ppp_2.4.5-4_i386.deb
    Afterwards you can compare /etc/chatscripts/gprs with the old one and make changes if they are necessary.

    dpkg: dependency problems prevent configuration of wvdial: wvdial depends on libuniconf4.6; however: Package libuniconf4.6 is not installed.
    I would search for a package /var/cache/apt/archives/libuniconf4.6*.deb and try to install it by issuing
    Code:
    dpkg -i /var/cache/apt/archives/libuniconf4.6*.deb
    if you can find it.

  5. #5
    Member registered user
    Join Date
    May 2009
    Posts
    32
    this worked ,then i used apt-get dist-upgrade -f . it encountered some errors with some mythtv packages . i forced override and then it encountered some error - that i cant remember .(now i cant make apt-get dist-upgrade -f again because the keyboard does not work so i can not see this error again) i typed dpkg --configure -a , init 2, init 5 and immediately after that computer asked for restart and after the restart ... things grew very ugly : there was new interface but i was unable to set up screen resolution , keyboard layout was still missing in system settings and most important - keyboard did not worked - did not react even to num lock , and computer asked for restart after the restart the situation was the same - low resolution and non working keyboard and asking for restart . after few restarts i gave up.... so is that way to recover knoppix hd install , or i have to do it from zero? it seems that apt-get upgrade is not possible , so perhaps there is some way to upgrade with next version of knoppix ? thanks best regards

  6. #6
    Senior Member registered user
    Join Date
    Feb 2010
    Posts
    511
    I think that you have some issue with the X environment. You do not need it to make an upgrade of your HDD install because I think that all files are already downloaded to you computer. It is recommended to run the command "apt-get dist-upgrade" while being in runlevel 2 to avoid issues with the X environment.

    The first thing I would try is to boot into runlevel 2 instead of the usual runlevel 5. If you boot your Knoppix system with GRUB you are able to edit the command line which starts Knoppix. You simply have to append the cheat code 2 to the line which begins with "kernel". After booting Knoppix you are in the console and could issue
    Code:
    apt-get -f install
    or
    Code:
    dpkg --configure -a
    You can reboot the system with the command
    Code:
    reboot
    if your keyboard is working again.

    In the case that your keyboard does not work although you booted into runlevel 2 you could boot off the Knoppix CD you were using for you HDD install and set up a chroot jail with your HDD install. Then it should be possible to complete the upgrade but this approach is more complicated than the first one I mentioned.

    so perhaps there is some way to upgrade with next version of knoppix ?
    It is not intended to upgrade Knoppix to a new version since its primary use is being a live CD and not a Linux system on an HDD.

  7. #7
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    it seems that apt-get upgrade is not possible , so perhaps there is some way to upgrade with next version of knoppix ?
    Why not upgrade Knoppix?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Atari Lynx ' Road Blasters ' Game Cartridge picture

Atari Lynx ' Road Blasters ' Game Cartridge

$16.99



atari picture

atari

$200.00



Atari 800XL Vintage Home Computer (Tested & Working) NTSC picture

Atari 800XL Vintage Home Computer (Tested & Working) NTSC

$250.00



Atari 600XL Computer Original Packaging  picture

Atari 600XL Computer Original Packaging

$95.00



ATARI SC1224 12

ATARI SC1224 12" Color Monitor for ST Version 2 | Normal Wear USED NOT TESTED

$120.00



Atari 800 POWER PCB TESTED WORKING NEW  picture

Atari 800 POWER PCB TESTED WORKING NEW

$29.95



atari 1200xl computer picture

atari 1200xl computer

$500.00



Atari 1040STF Computer, Mice And Disks - Tested And Working picture

Atari 1040STF Computer, Mice And Disks - Tested And Working

$500.00



Atari 1040ST w/ mouse and software and owners manual.  Powers on.  picture

Atari 1040ST w/ mouse and software and owners manual. Powers on.

$229.99



Atari Jaguar POWER PACK ORIGINAL 120/110VAC US TESTED WHITE LABEL  picture

Atari Jaguar POWER PACK ORIGINAL 120/110VAC US TESTED WHITE LABEL

$8.95