-
Continuing on getting nbd to work in Knoppix 6.7.1 (boot:knoppix64) - now with the knowledge that kernel has nbd -
the nbd server appears to start OK ("kvm-nbd -c /dev/nbd0 xp-disk.qcow2"), and fdisk shows partition 1 (as expected for the disk image xp-disk.qcow2). however, the device fails to mount ~ "mount /dev/nbd0p1 /mnt/xp-disk" gives the error message "mount: special device /dev/nbd0p1 does not exist").
A quick search points to the max_part parameter for nbd devices: "cat /sys/module/nbd/parameters/max_part" gives 0 (thus the failed mount). Had nbd been compiled as a module, it is said that "rmmod nbd" followed by "modprobe nbd max_part=16" would re-set the max_part parameter for mount to proceed. Given that nbd is compiled into the kernel in x86_64 in Knoppix 6.7.1, is it possible to change the parameter, and how? (it couldn't be editing directly the file in /sys/module/nbd/parameters/ - could it?)
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

Dell 6P85J 4TB ST4000NM0063 7.2k 6Gb/s 3.5” SAS SED Hard Drive with Tray
$39.99

Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5" 512e HDD NetApp X375A
$64.00

Seagate ST8000DM004 8TB 3.5" 6Gb/s 256MB SATA HDD P/N: 2CX188-300 Tested
$149.99

(ST8000NM0045) SEAGATE ENTERPRISE 8TB 7200RPM 4Kn SATA 6Gb/s 3.5" HARD DRIVE
$199.99

Seagate ST500DM009 BarraCuda 500 GB 3.5" SATA III Desktop Hard Drive
$14.99

HGST Ultrastar 7K4000 3TB 7200RPM SATA III 3.5" Hard Drive HDD HUS724030ALA640
$39.99

HGST HUA723030ALA640 3TB SATA 7200 RPM 3.5 in Enterprise HDD | 0F14044 (100%)
$45.00

Dell ST6000NM0034 1HT27Z-150 NWCCG 6TB SAS 3.5 7.2K ENTERPRISE SERVER DRIVE
$68.99

DELL 2TB Enterprise HDD (7200RPM, 3.5", SATA III, 128MB Cache) HUS722T2TALA600
$49.95

Seagate Exos X16 ST12000NM001G 12TB 256MB 7200RPM 3.5" SATA 6Gb/s Enterprise HDD
$349.95