Continuing on getting nbd to work in Knoppix 6.7.1 (boot:knoppix64) - now with the knowledge that kernel has nbd -

the nbd server appears to start OK ("kvm-nbd -c /dev/nbd0 xp-disk.qcow2"), and fdisk shows partition 1 (as expected for the disk image xp-disk.qcow2). however, the device fails to mount ~ "mount /dev/nbd0p1 /mnt/xp-disk" gives the error message "mount: special device /dev/nbd0p1 does not exist").

A quick search points to the max_part parameter for nbd devices: "cat /sys/module/nbd/parameters/max_part" gives 0 (thus the failed mount). Had nbd been compiled as a module, it is said that "rmmod nbd" followed by "modprobe nbd max_part=16" would re-set the max_part parameter for mount to proceed. Given that nbd is compiled into the kernel in x86_64 in Knoppix 6.7.1, is it possible to change the parameter, and how? (it couldn't be editing directly the file in /sys/module/nbd/parameters/ - could it?)