-
This "clash" with postgresql-common remains in KX7.0. Installing any language package for LO triggers an upgrade of all the LO components already installed. In my case, attempting to add the en-GB pack triggered an upgrade for LibreOffice, which in turn required an upgrade of python-uno and this triggered a re-setup of postgresql-common.
What appears to be happening is that as part of the configuration of postgresql-common by dpkg, a request to start the PostgreSQL-8.4 database server is made and this start process fails.
The consequent failure of the python-uno upgrade left a ".lock" file in place. Running "sudo apt-get -f install" after removing the lock file fixed most of the python-uno upgrade, except for the situation in postgresql-common.
Setting up postgresql-common (113) ...
Starting PostgreSQL 8.4 database server: mainThe PostgreSQL server failed to start. Please check the log output: 2012-04-11 22:12:12 BST FATAL: konnte Serverzertifikatsdatei >>server.crt<< nicht laden: Datei oder Verzeichnis nicht ge ... failed!
failed!
invoke-rc.d: initscript postgresql, action "start" failed.
dpkg: error processing postgresql-common (--configure):
subprocess installed post-installation script returned error exit status 1
configured to not write apport reports
Errors were encountered while processing:
postgresql-common
E: Sub-process /usr/bin/dpkg returned an error code (1)
The queston is ...why is dpkg requesting the database server to start? Is the server required in order for dpkg toconfigure an upgrade? If not, why the call?
I fixed the situation by removing postgresql-8.4 via apt-get, then running "sudo apt-get -f install" to clean up. That reported postgresql-common as suitable for autoremove, which I also ran.
Now both the LO language and help packages for en-GB went straight in, as did myspell-en-gb ... although I had to use "-t testing" to get the latest version of the dictionary.
No problems yet found from the removal of PostgreSQL. Any information as to whether I have put anything else at risk by this removal would be appreciated.
Tags for this Thread
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

2-Bay/4-Bay Hard Drive Enclosure for 3.5"/2.5'' SATA HDD/SSD 10Gbps USB-C 3.2
$75.99

OWC Express 4M2 4x M.2 NVMe RAID Enclosure Aluminum w/ SoftRAID
$199.00

OWC Mercury Elite Pro 2 Bay RAID Enclosure with USB 3.2 for Dual 3.5 inch HDDs
$87.99

Broadcom 9600-24i RAID Controller PCIe Gen 4.1 Tri-Mode NEW 05-50111-01004
$649.99

Acasis USB 3.2 2 Bay HDD RAID Enclosure for 2.5/3.5" SATA Drives External Array
$55.00

MegaRAID 9580-8i8e 16-port 12G SAS/SATA/NVMe 8GB PCIe RAID - 05-50076-00
$1619.19

Dell PowerEdge HBA330 LP PCI-E 12GBs RAID SAS Controller Adapter J7TNV
$18.95

NVME M.2 Adapter Card PCIE X16 Splitter Expansion Controller 4-Disk Soft RAID
$24.43

Intel VROC Premium RAID Controller Card PCIe Add-On Module VROCPREMMOD
$265.00

EMC KTN-SL3 15-Bay Disk Array Enclosure w/2x 303-108-000E Cards, Dual PSU,No HDD
$239.99