-
Junior Member
Text-mode mounting of NTFS volume causes XAUTHORITY error
I often boot to Knoppix 2 (the command-line). Up through Knoppix 6, I always mounted an NTFS volume first thing after getting to the command prompt:
Code:
mkdir /mnt/sda1
mount /dev/sda1 /mnt/sda1 -t ntfs -v -o noatime,utf8
Now, in Knoppix 7.0.5, on both the CD and DVD versions, I get the following error after attempting the mount:
Code:
No access to local display (XAUTHORITY=), exiting.
Booting to the Knoppix GUI and performing the same commands from a terminal window works, but I can't see why I can't mount NTFS without the GUI. Am I missing something?
-
Senior Member
registered user
Just a question: Would it help if you first booted X, and from there ran init 2? (I wonder if that Xauthority stuff has ever been really sane.)
Could seem like a bug to me, if the behavior is reproducible, in particular if it is fixed by bringing X up and down.
BTW, if you do this same mounting every time, you might put it in rc.local - that's what I ususally do.
-
Junior Member
After testing, I can confirm that the error occurs whenever I boot "knoppix 2", but never when I boot into the GUI, even after running "init 2" from a root terminal in the GUI. I expected "init 2" to close the GUI and kick me back to text mode (same as "knoppix 2"), but it didn't and had no visible effect whatsoever. I'm not convinced that "init 2" breaks XAUTHORITY after the GUI has already started. For now, I'm booting to the GUI and doing my business in a root terminal window. I would still love to get this fixed in text mode.
As far as automating my mounts, I run Knoppix from a DVD in various Windows boxes that I maintain. So that is not an option for me, thanks though.
-
Senior Member
registered user
At least, the old trick CTRL-ALT-F2 and CTRL-ALT-F5 works for switching back and forth between console and GUI.
But the whole problem definitely displays a type of bug.
Automating mounts: You could, of course do a remastering. If there is a workaround for this bug, remastering a patched DVD-version could be the best solution for you, in which case you could throw in any number of customizations.
-
Junior Member

Originally Posted by
Capricorny
At least, the old trick CTRL-ALT-F2 and CTRL-ALT-F5 works for switching back and forth between console and GUI.
But the whole problem definitely displays a type of bug.
Automating mounts: You could, of course do a remastering. If there is a workaround for this bug, remastering a patched DVD-version could be the best solution for you, in which case you could throw in any number of customizations.
Agreed on all counts. Thanks for your help, Capricorny! Instead of remastering I've considered installing Knoppix to a USB thumb drive and customizing that. With that, I can still boot to it on multiple computers with different hardware configurations, just as I do with the DVD, right?
-
Senior Member
registered user
Booting different devices/configurations, surely yes. And using a USB drive with persistent store, you can tweak most settings without remastering. Myself, I have started to use a USB3 cabinet mounted SSD drive as kind of "generalized thuimb drive" - with proper USB3 ports, it gives performance close to an internat SATA disk, so I can use it for both maintenance/emergency work, backup and ordinary running.
-
Junior Member
Update: I have solved my NTFS mounting troubles by switching to Debian Live Rescue.
-
Junior Member
registered user
Repaired

Originally Posted by
voidxor
I often boot to Knoppix 2 (the command-line). Up through Knoppix 6, I always mounted an NTFS volume first thing after getting to the command prompt:
Code:
mkdir /mnt/sda1
mount /dev/sda1 /mnt/sda1 -t ntfs -v -o noatime,utf8
Now, in Knoppix 7.0.5, on both the CD and DVD versions, I get the following error after attempting the mount:
Code:
No access to local display (XAUTHORITY=), exiting.
Booting to the Knoppix GUI and performing the same commands from a terminal window works, but I can't see why I can't mount NTFS without the GUI. Am I missing something?
It's a bug. The wrapper script checks for a hibernating NTFS partition, which is dangerous to mount rw, since Windows will destroy data when waking up and ignoring all changes you made.
In X mode, a graphical dialog will offer a few options in order to decide what to do next, while in textmode, it should just exit with an error message unless you specify the mount options manually. Unfortunately, the hadling of XAUTHORITY etc. was prior to checking for textmode, so it didn't work anymore on the console.
Please install the fixed package from http://debian-knoppix.alioth.debian....mount-knoppix/ , or just call
ntfs-3g.real instead.
Regards
-Klaus
-
Just experienced this error with 7.2.0 CD version when trying to mount an NTFS partition read-only (-o ro) in text mode.
Is this a different problem, or has the fix not made it into the latest release?
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

Dell 6P85J 4TB ST4000NM0063 7.2k 6Gb/s 3.5” SAS SED Hard Drive with Tray
$39.99

Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5" 512e HDD NetApp X375A
$64.00

Western Digital 1TB 3.5" SATA III 7200RPM Desktop Hard Drive
$34.99

DELL 2TB Enterprise HDD (7200RPM, 3.5", SATA III, 128MB Cache) HUS722T2TALA600
$49.95

Seagate ST4000NM0034 Enterprise 4TB 7200RPM SAS 12Gb/s HDD v4
$39.00

Seagate ST500DM009 BarraCuda 500 GB 3.5" SATA III Desktop Hard Drive
$14.99

Dell ST6000NM0034 1HT27Z-150 NWCCG 6TB SAS 3.5 7.2K ENTERPRISE SERVER DRIVE
$68.99

Toshiba 14TB MG07 MG07ACA14TEY 7.2K RPM SATA 6Gb/s 512e 3.5" Enterprise HDD
$329.00

Seagate ST12000NM0127 12TB 256MB 7200RPM 3.5" SATA 6.0Gb/s Enterprise Hard Drive
$318.99

Seagate ST8000NM0075 Enterprise Capacity 3.5 HDD 8TB SAS Hard Drive 8TB EXOS
$184.99