Quote Originally Posted by moritz.b View Post
I have my problem solved with a new cheatcode and adaption the init.

moritz.b
I have two concerns with the initial premise here.

Unless your Knoppix user is denied root privileges,
making that partition which contains /mnt-system read-only on a write-able
medium offers no real protection against unauthorized changes to the contents
of /mnt-system.

If the Knoppix user is denied root privileges completely,
there are many useful things his Knoppix can't do.

I'd like to see how changes to init might get around these considerations.