Results 1 to 8 of 8

Thread: layout switching not working in knoppix 7.2 - this becomes a tradition

  1. #1
    Member registered user
    Join Date
    May 2009
    Posts
    32

    layout switching not working in knoppix 7.2 - this becomes a tradition

    Again i have problems with layout switching - this time in KNOPPIX 7.2
    i used menu preferences>KDE system settings > input devices > keyboard > layouts
    here i added new layout configure layouts is checked ,show layout indicator is checked
    in advanced configure keyboard options is checked
    in key(s) to change layout "left alt + left shift"is checked
    apply is pressed
    AND ...
    No layout indicator is shown and pressing left alt + left shift does not change the layout
    setxkbmap works but sets layout for the correct language but different from that i set in KDE system settings

    i look back and i see this problem is here since version 6.2 and is not fixed yet!
    So what it turns out ? KNOOPIX does not support keyboard layout switching ?
    Can someone help me to make knoppix 7.2 switching layouts from GUI?
    Thanks
    Best regards

  2. #2
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    KDE system settings are for the KDE and not the LXDE desktop. Please try
    Knoppix => Chose Restart KNOPPIX Desktop => kde => [OK]
    Do your settings and you'll see the keyboard layout indicator and also the shortcut for switching layout will work.

  3. #3
    Member registered user
    Join Date
    May 2009
    Posts
    32
    in version 6 this was working for lxde. and why kde system settings is mentioned in preferences ? it not working for lxde. and there is no lxde system settings. Isn`t it strange ?
    there was some haiku error messages in internet
    one of them was: yesterday it was working , today it does not working, windows goes this way...
    but seems linux too , and it goes much further...

    so what to do to have keyboard layout switching in lxde gui ?


    thanks
    Best rgards

  4. #4
    Moderator Moderator
    Join Date
    Nov 2010
    Location
    Germany/ Dietzenbach
    Posts
    1,124
    Open (as root) the file '/etc/xdg/lxsession/LXDE/autostart' and append
    Code:
    @setxkbmap -option grp:switch,grp:alt_shift_toggle us,de
    Do also "Right-click on the panel => Add / Remove Panel Items => Add => Keyboard Layout Switcher"

    Restart the LXDE session. In this example you can use the icon within the panel or [Alt Shift] to toggle. Instead of "us,de" use the keyboard settings you would prefer.

  5. #5
    Member registered user
    Join Date
    May 2009
    Posts
    32
    Quote Originally Posted by Werner P. Schulz View Post
    Open (as root) the file '/etc/xdg/lxsession/LXDE/autostart' and append
    Code:
    @setxkbmap -option grp:switch,grp:alt_shift_toggle us,de
    Do also "Right-click on the panel => Add / Remove Panel Items => Add => Keyboard Layout Switcher"

    Restart the LXDE session. In this example you can use the icon within the panel or [Alt Shift] to toggle. Instead of "us,de" use the keyboard settings you would prefer.
    Yes! This works!

    Thanks

    Best regards

  6. #6
    Junior Member
    Join Date
    Jun 2016
    Posts
    4
    how to open as root?I tried "knoppix->Root Shell" and typed " /etc/xdg/lxsession/LXDE/autostart", but encountered "Permission denied".Now what i have to do?Thanks.

  7. #7
    Junior Member
    Join Date
    Jun 2016
    Posts
    4
    hi, how to open "autostart", as root.I tried "Knoppix->Root Shell" and typed "/etc/xdg/lxsession/LXDE/autostart" and encountered "Permission Denied".Know what I have to do?Thanks.

  8. #8
    Junior Member
    Join Date
    Jun 2016
    Posts
    4

    how to open as root?

    Quote Originally Posted by Werner P. Schulz View Post
    Open (as root) the file '/etc/xdg/lxsession/LXDE/autostart' and append
    Code:
    @setxkbmap -option grp:switch,grp:alt_shift_toggle us,de
    Do also "Right-click on the panel => Add / Remove Panel Items => Add => Keyboard Layout Switcher"

    Restart the LXDE session. In this example you can use the icon within the panel or [Alt Shift] to toggle. Instead of "us,de" use the keyboard settings you would prefer.
    Hi,
    I tried to open file as root in the following way:
    "Knoppix->Root Shell" and tried the command "/etc/xdg/lxsession/LXDE/autostart", but encountered the error, "permission denied".
    what I have to do?
    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Dell PowerEdge R720 Server / 2x E5-2630 = 12 Cores / 16GB RAM / H710 picture

Dell PowerEdge R720 Server / 2x E5-2630 = 12 Cores / 16GB RAM / H710

$323.95



Dell PowerEdge R410 Server | 2x E5645 = 12-Cores | 32GB | SAS6i | 2x 300GB SAS picture

Dell PowerEdge R410 Server | 2x E5645 = 12-Cores | 32GB | SAS6i | 2x 300GB SAS

$248.95



Supermicro 2U X8DT3 2x X5650 2.66ghz 12-Cores / 24gb Ram / 12x Trays / 2x720w picture

Supermicro 2U X8DT3 2x X5650 2.66ghz 12-Cores / 24gb Ram / 12x Trays / 2x720w

$199.99



Supermicro 2U X8DT3 2x E5620 2.4ghz 8-Cores / 24gb Ram / 12x Trays / 2x 720w picture

Supermicro 2U X8DT3 2x E5620 2.4ghz 8-Cores / 24gb Ram / 12x Trays / 2x 720w

$179.99



Dell PowerEdge R720 8B SFF Server 2x E5-2620 2.0GHz 12 Cores 16GB RAM H310 picture

Dell PowerEdge R720 8B SFF Server 2x E5-2620 2.0GHz 12 Cores 16GB RAM H310

$274.99



Dell PowerEdge R320 Server / E5-2430 2.2GHz 6 Cores / 8GB RAM / 4x Trays picture

Dell PowerEdge R320 Server / E5-2430 2.2GHz 6 Cores / 8GB RAM / 4x Trays

$214.95



Dell PowerEdge R620 Server | 2x 2.00GHz 12 Cores | 32GB | H710 | 146GB SAS picture

Dell PowerEdge R620 Server | 2x 2.00GHz 12 Cores | 32GB | H710 | 146GB SAS

$199.99



Dell PowerEdge R420 3.5

Dell PowerEdge R420 3.5" Server, 2x E5-2420 1.9GHz 6Core, 16GB, 4x Trays, H710

$199.99



Dell PowerEdge R710 2.5

Dell PowerEdge R710 2.5" 2U Server 2x X5670 2.93GHZ 12-Core 128gb 2xTrays Perc6i

$294.99



Supermicro 2U Server Chassis CSE-826 SAS-826TQ Backplane 2x 720w PSU picture

Supermicro 2U Server Chassis CSE-826 SAS-826TQ Backplane 2x 720w PSU

$89.99