I suggest that you load the configuration file /home/knoppix/.config/akonadi/akonadiserverrc in a texteditor and change
Code:
[QMYSQL]
StartServer=false
into
Code:
[QMYSQL]
StartServer=true
Save the file and exit the texteditor.
Issue the command
Code:
kmail
in an LXTerminal and wait until kmail runs properly or exits with an error message.

Tell us if that resolved the issue.