-
ifconfig output format change breaks scripts ( knoppix-terminalserver )
Hi Klaus,
I just woul like to bring to your attention that the output format of the "ifconfig" program have now changed
which now breaks multiple scripts, knoppix-terminalserver being one of them. Knoppix 7.5.0 was still ok.
cf: https : / / bugzilla.redhat.com/show_bug.cgi?id=784314
I also have trouble getting the vmware tools to autostart and have the cut & paste working between
the host and the guest vm. It is probablly not related to the above problem. Any idea ?
Best Regards,
Gilles
(new) ifconfig as in Knoppix 7.6.0
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 metric 1
inet 172.17.17.17 netmask 255.255.255.0 broadcast 172.17.17.255
inet6 fe80::5054:ff:fe3f:c083 prefixlen 64 scopeid 0x20<link>
ether 52:54:00:3f:c0:83 txqueuelen 1000 (Ethernet)
RX packets 339806 bytes 317184647 (302.4 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 158189 bytes 14694182 (14.0 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
(old) ifconfig as in Knoppix 7.5.0
eth0 Link encap:Ethernet HWaddr 52:54:00:A3:98:1B
inet addr:172.17.17.15 Bcast:172.17.17.255 Mask:255.255.255.0
inet6 addr: fe80::5054:ff:fea3:981b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:678733 errors:0 dropped:0 overruns:0 frame:0
TX packets:176576 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:362735982 (345.9 MiB) TX bytes:15404448 (14.6 MiB)
-
Senior Member
registered user

Originally Posted by
ruymbeke
I just woul like to bring to your attention that the output format of the "ifconfig" program have now changed
which now breaks multiple scripts, knoppix-terminalserver being one of them. Knoppix 7.5.0 was still ok.
cf: https : / / bugzilla.redhat.com/show_bug.cgi?id=784314
1--I think you may have better luck getting Klaus K on Debian-Knoppix mailing list.
2--Regarding your query, I also had some of my pet tweaks stop working recently.
It seems that in my case iwlist no longer works as before. However, I found the nmcli does a lot more.
You may see my example at http://knoppix.net/forum/threads/317...ighlight=nmcli
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

2-Bay/4-Bay Hard Drive Enclosure for 3.5"/2.5'' SATA HDD/SSD 10Gbps USB-C 3.2
$75.99

Broadcom 9600-24i RAID Controller PCIe Gen 4.1 Tri-Mode NEW 05-50111-01004
$649.99

OWC Mercury Elite Pro 2 Bay RAID Enclosure with USB 3.2 for Dual 3.5 inch HDDs
$87.99

Areca ARC-1882IX-24 (16i4e)24-Port RAID Controller Card w/BBU /HDD Monitor Board
$300.00

Acasis USB 3.2 2 Bay HDD RAID Enclosure for 2.5/3.5" SATA Drives External Array
$55.00

WAVLINK RAID 2 Bay Hard Drive Docking Station SATA 2.5/3.5'' SSD HDD Enclosure
$119.99

G-Technology G-RAID 24TB Dual-Drive External HDD TB3 USB 3.1 7200RPM Silver
$299.99

Dell PowerEdge HBA330 LP PCI-E 12GBs RAID SAS Controller Adapter J7TNV
$18.95

Intel VROC Premium RAID Controller Card PCIe Add-On Module VROCPREMMOD
$265.00

CalDigit VR minin 2 Portable Raid Storage On The Go
$75.00