I followed the instructions by marlas to create a 'knoppified debian live cd'. The original list of repositories
/etc/apt/sources.list was replaced with the one from Knoppix 7.6.0 before running 'apt-get update' for the first time.

The Debian live CD standard comes without the desktop environment. I installed the lxde meta package plus the packages
xinit and lxde-common. I used the package list of Knoppix 7.6.0 to decide which packages are to be installed.

Since not all knoppix packages were available in the repository I created a few from Knoppix 7.6.0 with the debian-repack
command: bluez-utils, bttool-knoppix, cgroup-remove-knoppix, knoppix-udev-config, lxsession, network-setup-knoppix,
openssh-client, openssh-server, openssh-sftp-server, rootshell-knoppix, scanpartitions-knoppix, ssh, ssh-askpass,
sshstart-knoppix, sysvinit, sysv-rc, usleep-knoppix, x11-xserver-utils. It was necessary to create the group nm-openvpn
with gid 154 manually before all packages for the networkmanager could be properly installed.

In addition to the instructions in post #1 I added the user knoppix with uid 1000 before I copied the directory
/home/knoppix from Knoppix 7.6.0. I also added the user knoppix to the groups disk, dialout, fax, voice, cdrom, floppy,
tape, sudo, audio, dip, backup, video, plugdev, users, fuse, netdev.

The files in the directories /etc/polkit-1/localauthority/10-vendor.d and /etc/dbus-1/system.d were copied to the
corresponding remastering directories. I also copied the directory /lib/udev/devices to the remastering directory.

The ISO is 890 MB large.

The remastered ISO boots as describe by marlas. In runlevel 5 it fails to start the desktop environment. There appeared an
error message
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
I created a file /home/knoppix/.xinitrc with the single command
Code:
exec startlxde
The file is owned by the user
knoppix. In runlevel 2 after
Code:
su - knoppix
startx
I found the following error message in the logfile /home/knoppix/.local/share/xorg/Xorg.0.log
(EE) systemd-logind: failed to get session: Failed to execute program org.freedesktop.login1: Permission denied
What has to be done to solve the issue?

Btw. root is allowed to start the desktop environment if I create a file .xinitrc in / with the line 'exec startlxde'.