-
Senior Member
registered user
I followed the instructions by marlas to create a 'knoppified debian live cd'. The original list of repositories
/etc/apt/sources.list was replaced with the one from Knoppix 7.6.0 before running 'apt-get update' for the first time.
The Debian live CD standard comes without the desktop environment. I installed the lxde meta package plus the packages
xinit and lxde-common. I used the package list of Knoppix 7.6.0 to decide which packages are to be installed.
Since not all knoppix packages were available in the repository I created a few from Knoppix 7.6.0 with the debian-repack
command: bluez-utils, bttool-knoppix, cgroup-remove-knoppix, knoppix-udev-config, lxsession, network-setup-knoppix,
openssh-client, openssh-server, openssh-sftp-server, rootshell-knoppix, scanpartitions-knoppix, ssh, ssh-askpass,
sshstart-knoppix, sysvinit, sysv-rc, usleep-knoppix, x11-xserver-utils. It was necessary to create the group nm-openvpn
with gid 154 manually before all packages for the networkmanager could be properly installed.
In addition to the instructions in post #1 I added the user knoppix with uid 1000 before I copied the directory
/home/knoppix from Knoppix 7.6.0. I also added the user knoppix to the groups disk, dialout, fax, voice, cdrom, floppy,
tape, sudo, audio, dip, backup, video, plugdev, users, fuse, netdev.
The files in the directories /etc/polkit-1/localauthority/10-vendor.d and /etc/dbus-1/system.d were copied to the
corresponding remastering directories. I also copied the directory /lib/udev/devices to the remastering directory.
The ISO is 890 MB large.
The remastered ISO boots as describe by marlas. In runlevel 5 it fails to start the desktop environment. There appeared an
error message
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
I created a file /home/knoppix/.xinitrc with the single command The file is owned by the user
knoppix. In runlevel 2 after
Code:
su - knoppix
startx
I found the following error message in the logfile /home/knoppix/.local/share/xorg/Xorg.0.log
(EE) systemd-logind: failed to get session: Failed to execute program org.freedesktop.login1: Permission denied
What has to be done to solve the issue?
Btw. root is allowed to start the desktop environment if I create a file .xinitrc in / with the line 'exec startlxde'.
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

🔀 Juniper Networks EX2300-C-12P 12× Gigabit PoE+ • 2× 10G SFP+ Compact Switch ⚡
$109.99

Juniper EX2300 12-Port Gigabit PoE+ Managed Network Switch P/N: EX2300-C-12P
$149.99

Juniper Networks EX3400-24T 24-Port Ethernet Switch w/Power Cord
$174.99

Juniper EX3400-24P 24-Port PoE+ GbE + 4-Port 1/10Gb SFP Switch
$245.00

Juniper MX204 +JUNOS and Dual Power Supply
$7299.99

Juniper MPC2E-3D-NG-Q / New / 1 Year Warranty / Ships Today
$6995.00

Juniper Networks AP33-US Indoor Wifi6 (US Version) 5GHz: 4x4:4; 2.99
$24.99

Juniper Networks 25GBASE-LR SMF 25Gbps 10km 1310nm LC SFP 740-071562 Lot 10
$1200.00

Juniper Networks Mist Wireless Access Points, Model AP45
$59.99

Juniper Networks AP33 Wireless Access Point Bluetooth WiFi 6 Cloud Managed NIB
$54.99