-
I've tried this again. This time I configured the knoppix-box started in text-mode (cheatcode: knoppix 2 expert) and logged in as user knoppix.
Of course I did give knoppix a password by typing:
, etc., etc., etc.
The result on the Win98-box are the same as earlier.
On my knoppix-box console the following apeared:
Code:
ftp(pam-unix)[947]: authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=192.168.0.51 user=knoppix
ftp(pam-unix)[954]: auth could not identify password for [ftp]
I am sure I used the right password and username.
I also tried on the Win98-box in IE 6.0 to use the following adress:
IE explorer did exactly the same as when I typed
So what could there be wrong?
I think there might be 2 causes for this:
1. I do something wrong in the host-file.
Maybe the information I put in the host-file about the knoppix-machine is wrong.
I did gave some information about the client, but I think that should not be needed.
If it's needed I still have a problem when I want to connect over the internet.
I do not always know in front on which machine I'm working.
Or should I just put in the information of the firewall/router which will be the first hop for the knoppix-box?
2. There is something wrong with the user.
I'm still getting error-messages when adding a user with adduser
I hope someone can answer me what I have to do to get things working.
Thanks.
-
Senior Member
registered user
--I updated the instructions again, and have used them myself several times now in the past couple of days. Suggestion:
1. Do *everything* exactly as written, in Knoppix, from text-mode root console (Ctrl-Alt-F1) - real sysadmins don't use GUI for configuration... :P
2. Boot Knoppix also on the *client* machine, and manually ifconfig eth0 to
"ifconfig eth0 10.0.0.2 netmask 255.0.0.0 up"
--Then see if it works using ncftp as described. Once you have it working, you can reboot the client box to Win and try it from there. (Of course you will have to reconfig the server for 192.168... and the new netmask, but Linux makes it easy.) If it still doesn't work on the Win side, try the DOS ftp client.

Originally Posted by
Hermanh
I've tried this again.
The result on the Win98-box are the same as earlier.
On my knoppix-box console the following apeared:
Code:
ftp(pam-unix)[947]: authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=192.168.0.51 user=knoppix
ftp(pam-unix)[954]: auth could not identify password for [ftp]
I am sure I used the right password and username.
I also tried on the Win98-box in IE 6.0 to use the following adress:
IE explorer did exactly the same as when I typed
So what could there be wrong?
I think there might be 2 causes for this:
1. I do something wrong in the host-file.
Maybe the information I put in the host-file about the knoppix-machine is wrong.
I did gave some information about the client, but I think that should not be needed.
If it's needed I still have a problem when I want to connect over the internet.
I do not always know in front on which machine I'm working.
Or should I just put in the information of the firewall/router which will be the first hop for the knoppix-box?
2. There is something wrong with the user.
I'm still getting error-messages when adding a user with
adduser
I hope someone can answer me what I have to do to get things working.
Thanks.
-
The FTP-server is working.
I'm in! (from
The problem was the file ftpusers. This was also a symlink. As soon as I removed that link and copied the file from /KNOPPIX/etc to /etc the problem was solved.
I did also do some changing on the file hosts, but that did not solve the problem.
I came to the right answer by an error-message on the console after 5 retries.
Dave_Bechtel thanks for your time and everything. I know how desperate one can get if not exactly is done what you asked. Or how difficult it is to get your hands on the right spot when things go wrong. I do a lot of support for Windows on a dutch forum. So I know exactly how it feels. Again, thanks a lot.
-
I've tried it again with my old file hosts. And it does work also. So I did read the man-pages on hosts right. If you use a non dotted host-name you are supposed to be in the same network.
I think I just should let you know.
Again thanks.
-
Senior Member
registered user
--Glad it finally worked.
I kinda suspected the ftpusers file, but in the latest ISO rev it's not a problem. Always make sure you have the latest DL. 

Originally Posted by
Anonymous
The FTP-server is working.
I'm in! (from
The problem was the file ftpusers. This was also a symlink. As soon as I removed that link and copied the file from /KNOPPIX/etc to /etc the problem was solved.
I did also do some changing on the file hosts, but that did not solve the problem.
I came to the right answer by an error-message on the console after 5 retries.
Dave_Bechtel thanks for your time and everything. I know how desperate one can get if not exactly is done what you asked. Or how difficult it is to get your hands on the right spot when things go wrong. I do a lot of support for Windows on a dutch forum. So I know exactly how it feels. Again, thanks a lot.
-
Just for a little bit more security:
I changed the file hosts.allow
It looks now like this:
Code:
inetd : ALL@ALL ALLOW
ALL : 127.0.0.1 LOCAL : ALLOW
ALL : ALL@ALL : DENY
-
Also for security reasons I did change several settings in inetd.conf.
From the external services is now only FTP running.
-
for knoppix-doc
ok ... that was cool... if it is ok with everyone i think i will clean this post up a little and make it one of the how-to's on the knoppix doc forum. let me know if youy have any special requests, or objections.
http://sourceforge.net/docman/?group_id=70773
toast
again dave is da' man :-p
-
done all of the above
hey everyone, i have gotten my ftp up and running just fine thanks to all of you.....but one question....i have my hard drive mounted but how do i get to it from the ftp?
all i can see the ramdrive
thanks
-
Senior Member
registered user
Does any of the above apply if I just want to ftp across a LAN (intranet - in my lab at school). I tried everything in FAQFTP and got no where....
I rm'd hosts.deny and hosts.allow and restarted inetd on the "ftp server" but when I ftp from a client I get a time out after logging-in and just trying to ls! BTW, the client is a KNOPPIX liveCD and the server is knoppix-intalled as debian.
Please help!
TIA,
Similar Threads
-
By lastinger in forum Networking
Replies: 7
Last Post: 09-22-2004, 03:52 AM
-
By Lord1981 in forum Hdd Install / Debian / Apt
Replies: 6
Last Post: 01-04-2004, 10:19 PM
-
By cmcclean in forum General Support
Replies: 1
Last Post: 10-03-2003, 01:52 PM
-
By jimbo70 in forum Ideas
Replies: 5
Last Post: 04-23-2003, 10:58 PM
-
By Robert Michel in forum Ideas
Replies: 0
Last Post: 02-26-2003, 01:21 AM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

IBM System X3850-X5 Server w/4x Intel Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD
$1299.99

Unused IBM 09P0037 MAINBOARD For RS/6000 7044-170 P-Series
$375.00

IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM
$179.99

IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon E5620
$199.99

IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES
$110.30

Compaq ProLiant 1500R 5/100 rack server, Series 3155, with IBM 2.1GB HD, VINTAGE
$295.00

IBM Power S824 12Bay 4U Server - 2x Power8 CPU, 512GB DDR4, MT: 8286-42A
$1731.00

IBM SYSTEM X3550 M5 5463AC1 2.5x8 Server 2*XEON E5-2640 V3 8GB SEE NOTES
$85.99

Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs
$49.99

IBM Server Rackmount Sliding Rail Kit ( Part Numbers: 00D9375 / 00D9374 )
$24.99