Results 1 to 4 of 4

Thread: Nessus fails

Hybrid View

  1. #1
    Junior Member
    Join Date
    Jan 2003
    Posts
    3

    Nessus fails

    Nessus (local client, local server) seems to fail. I'll keep looking at it, but here's what I know:

    Using the 1.1.03 version (3.1?) of Knoppix-EN.

    When I run 'nessusd -D', Nessus complains about a certificate:
    *** 'ca_file' is not set - did you run nessus-mkcert ?

    According to msgs on google, this was due to a bad RPM, and getting a new/fixed RPM solved the problem.

    Has anyone had better luck with this? So far, I have:

    Attempted to apt-get install nessusd, since I know debian better than RPM's (Linux's answer to .dll hell): apt-get Result wasn't pretty. Uglier still when I did an apt-get update.

    running nessus-mkcert did have one error in the midst of it:
    ------------------------ snip
    Congratulations. Your server certificate was properly created.

    mv: cannot stat `/etc/nessus/nessusd.conf.tmp': No such file or directory
    /etc/nessus/nessusd.conf updated

    The following files were created :

    . Certification authority :
    Certificate = /var/lib/nessus/CA/cacert.pem
    Private key = /var/lib/nessus/private/CA/cakey.pem

    . Nessus Server :
    Certificate = /var/lib/nessus/CA/servercert.pem
    Private key = /var/lib/nessus/private/CA/serverkey.pem
    --------------------- end snip
    ... but since /etc/nessus/nessusd.conf is created, I figured that was ok.

    I've never edited/altered nessusd.conf before, so it might be possible to alter nessusd behavior to not insist on certificates.

    Throughout, it seems like there's a chance I'll find something is unable to write due to read/write permissions limitations (I've found several X-based utilities that don't like everything being owned by root, when I try to save files).

  2. #2
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Auckland, New Zealand
    Posts
    818
    there is a "start nessus" menu option in the kde knoppix menu, you probally have to use that as it may start nessusd with some special options.

  3. #3
    Junior Member
    Join Date
    Jan 2003
    Location
    San Francisco
    Posts
    2
    nessus-mkcert normally updates the /etc/nessus/nessusd.conf file. On Knoppix, this is a symlink to the KNOPPIX loopback on the CD-ROM, so nessusd.conf is readonly. The nessus-mkcert program cannot update the conf file, but does not report the error.

    You can delete the symlink, manually copy the KNOPPIX/etc/nessus/ version of the file, then run nessus-mkcert. This will work.

    There is also a 'Start Nessus' menu item under the KDE system on Knoppix. It probably automates these steps - I haven't yet used this.

  4. #4
    Member registered user
    Join Date
    Dec 2002
    Location
    Thousand Oaks, CA
    Posts
    96
    Nessus does run from the CD if started from the KDE...System...Security menu. Use a user name of knoppix and a password of knoppix. It worked for me, though it seemed slower than usual at scanning.

Similar Threads

  1. problem with nessus
    By happyholger in forum Networking
    Replies: 0
    Last Post: 10-12-2003, 12:28 PM
  2. need help with nessus
    By happyholger in forum Customising & Remastering
    Replies: 0
    Last Post: 10-03-2003, 05:31 PM
  3. Nessus plugins, again....
    By jafo in forum General Support
    Replies: 0
    Last Post: 04-27-2003, 11:24 AM
  4. Nessus plugins
    By timix in forum General Support
    Replies: 2
    Last Post: 04-16-2003, 07:04 PM
  5. Nessus startup
    By s3nt3nza in forum General Support
    Replies: 4
    Last Post: 04-12-2003, 02:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


OWC Mercury Elite Pro 2 Bay RAID Enclosure with USB 3.2  for Dual 3.5 inch HDDs picture

OWC Mercury Elite Pro 2 Bay RAID Enclosure with USB 3.2 for Dual 3.5 inch HDDs

$87.99



Broadcom MegaRAID 9480-8e Fujitsu PRAID EP540e SAS RAID Card (Replac 9380-8e) 8i picture

Broadcom MegaRAID 9480-8e Fujitsu PRAID EP540e SAS RAID Card (Replac 9380-8e) 8i

$228.00



G-Technology G-SPEED Studio XL 48TB Thunderbolt 2 Storage - Housing Only picture

G-Technology G-SPEED Studio XL 48TB Thunderbolt 2 Storage - Housing Only

$200.00



Broadcom 9600-24i RAID Controller PCIe Gen 4.1 Tri-Mode NEW 05-50111-01004 picture

Broadcom 9600-24i RAID Controller PCIe Gen 4.1 Tri-Mode NEW 05-50111-01004

$649.99



MegaRAID 9580-8i8e 16-port 12G SAS/SATA/NVMe 8GB PCIe RAID - 05-50076-00 picture

MegaRAID 9580-8i8e 16-port 12G SAS/SATA/NVMe 8GB PCIe RAID - 05-50076-00

$1619.19



Broadcom LSI 9305-16i 12Gbps SAS-3 PCIe x8 HBA 16-Ports Raid Controller picture

Broadcom LSI 9305-16i 12Gbps SAS-3 PCIe x8 HBA 16-Ports Raid Controller

$64.99



Dell PowerEdge HBA330 LP PCI-E 12GBs RAID SAS Controller Adapter J7TNV picture

Dell PowerEdge HBA330 LP PCI-E 12GBs RAID SAS Controller Adapter J7TNV

$18.95



NVME M.2 Adapter Card PCIE X16 Splitter Expansion Controller 4-Disk Soft RAID picture

NVME M.2 Adapter Card PCIE X16 Splitter Expansion Controller 4-Disk Soft RAID

$24.43



Areca ARC-1882IX-24 (16i4e)24-Port RAID Controller Card w/BBU /HDD Monitor Board picture

Areca ARC-1882IX-24 (16i4e)24-Port RAID Controller Card w/BBU /HDD Monitor Board

$300.00



Intel VROC Premium RAID Controller Card PCIe Add-On Module VROCPREMMOD picture

Intel VROC Premium RAID Controller Card PCIe Add-On Module VROCPREMMOD

$265.00