Results 1 to 4 of 4

Thread: Nessus fails

  1. #1
    Junior Member
    Join Date
    Jan 2003
    Posts
    3

    Nessus fails

    Nessus (local client, local server) seems to fail. I'll keep looking at it, but here's what I know:

    Using the 1.1.03 version (3.1?) of Knoppix-EN.

    When I run 'nessusd -D', Nessus complains about a certificate:
    *** 'ca_file' is not set - did you run nessus-mkcert ?

    According to msgs on google, this was due to a bad RPM, and getting a new/fixed RPM solved the problem.

    Has anyone had better luck with this? So far, I have:

    Attempted to apt-get install nessusd, since I know debian better than RPM's (Linux's answer to .dll hell): apt-get Result wasn't pretty. Uglier still when I did an apt-get update.

    running nessus-mkcert did have one error in the midst of it:
    ------------------------ snip
    Congratulations. Your server certificate was properly created.

    mv: cannot stat `/etc/nessus/nessusd.conf.tmp': No such file or directory
    /etc/nessus/nessusd.conf updated

    The following files were created :

    . Certification authority :
    Certificate = /var/lib/nessus/CA/cacert.pem
    Private key = /var/lib/nessus/private/CA/cakey.pem

    . Nessus Server :
    Certificate = /var/lib/nessus/CA/servercert.pem
    Private key = /var/lib/nessus/private/CA/serverkey.pem
    --------------------- end snip
    ... but since /etc/nessus/nessusd.conf is created, I figured that was ok.

    I've never edited/altered nessusd.conf before, so it might be possible to alter nessusd behavior to not insist on certificates.

    Throughout, it seems like there's a chance I'll find something is unable to write due to read/write permissions limitations (I've found several X-based utilities that don't like everything being owned by root, when I try to save files).

  2. #2
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Auckland, New Zealand
    Posts
    818
    there is a "start nessus" menu option in the kde knoppix menu, you probally have to use that as it may start nessusd with some special options.

  3. #3
    Junior Member
    Join Date
    Jan 2003
    Location
    San Francisco
    Posts
    2
    nessus-mkcert normally updates the /etc/nessus/nessusd.conf file. On Knoppix, this is a symlink to the KNOPPIX loopback on the CD-ROM, so nessusd.conf is readonly. The nessus-mkcert program cannot update the conf file, but does not report the error.

    You can delete the symlink, manually copy the KNOPPIX/etc/nessus/ version of the file, then run nessus-mkcert. This will work.

    There is also a 'Start Nessus' menu item under the KDE system on Knoppix. It probably automates these steps - I haven't yet used this.

  4. #4
    Member registered user
    Join Date
    Dec 2002
    Location
    Thousand Oaks, CA
    Posts
    96
    Nessus does run from the CD if started from the KDE...System...Security menu. Use a user name of knoppix and a password of knoppix. It worked for me, though it seemed slower than usual at scanning.

Similar Threads

  1. problem with nessus
    By happyholger in forum Networking
    Replies: 0
    Last Post: 10-12-2003, 12:28 PM
  2. need help with nessus
    By happyholger in forum Customising & Remastering
    Replies: 0
    Last Post: 10-03-2003, 05:31 PM
  3. Nessus plugins, again....
    By jafo in forum General Support
    Replies: 0
    Last Post: 04-27-2003, 11:24 AM
  4. Nessus plugins
    By timix in forum General Support
    Replies: 2
    Last Post: 04-16-2003, 07:04 PM
  5. Nessus startup
    By s3nt3nza in forum General Support
    Replies: 4
    Last Post: 04-12-2003, 02:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p picture

Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p

$499.88



Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram  2x 550W PSU No HDD picture

Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD

$275.00



Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb picture

Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb

$374.99



Dell PowerEdge R730XD 28 Core Server 2X Xeon E5-2680 V4 H730 32GB RAM No HDD picture

Dell PowerEdge R730XD 28 Core Server 2X Xeon E5-2680 V4 H730 32GB RAM No HDD

$378.93



Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Core | HBA330 | No RAM or HDD picture

Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Core | HBA330 | No RAM or HDD

$149.99



Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W picture

Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W

$409.99



Dell PowerEdge R730 8 Bay Server 64Gb 1x80Gb SSD 3x900Gb SAS 2x12c v4CPU Proxmox picture

Dell PowerEdge R730 8 Bay Server 64Gb 1x80Gb SSD 3x900Gb SAS 2x12c v4CPU Proxmox

$620.00



Dell Poweredge R810 4x Xeon X7560 2.26ghz 32-Cores | 256GB | 3x Trays | H700 picture

Dell Poweredge R810 4x Xeon X7560 2.26ghz 32-Cores | 256GB | 3x Trays | H700

$289.99



Dell Poweredge R620 10x 2.5

Dell Poweredge R620 10x 2.5" bay with 256GB (16x16gb) DDR3, 2x E5-2690v2, H710

$349.99



Dell Poweredge C4130 2x LGA2011-3 1U 4x GPU Rackmount Server CTO (NO CPU/NO RAM) picture

Dell Poweredge C4130 2x LGA2011-3 1U 4x GPU Rackmount Server CTO (NO CPU/NO RAM)

$299.95