Results 1 to 4 of 4

Thread: Nessus fails

  1. #1
    Junior Member
    Join Date
    Jan 2003
    Posts
    3

    Nessus fails

    Nessus (local client, local server) seems to fail. I'll keep looking at it, but here's what I know:

    Using the 1.1.03 version (3.1?) of Knoppix-EN.

    When I run 'nessusd -D', Nessus complains about a certificate:
    *** 'ca_file' is not set - did you run nessus-mkcert ?

    According to msgs on google, this was due to a bad RPM, and getting a new/fixed RPM solved the problem.

    Has anyone had better luck with this? So far, I have:

    Attempted to apt-get install nessusd, since I know debian better than RPM's (Linux's answer to .dll hell): apt-get Result wasn't pretty. Uglier still when I did an apt-get update.

    running nessus-mkcert did have one error in the midst of it:
    ------------------------ snip
    Congratulations. Your server certificate was properly created.

    mv: cannot stat `/etc/nessus/nessusd.conf.tmp': No such file or directory
    /etc/nessus/nessusd.conf updated

    The following files were created :

    . Certification authority :
    Certificate = /var/lib/nessus/CA/cacert.pem
    Private key = /var/lib/nessus/private/CA/cakey.pem

    . Nessus Server :
    Certificate = /var/lib/nessus/CA/servercert.pem
    Private key = /var/lib/nessus/private/CA/serverkey.pem
    --------------------- end snip
    ... but since /etc/nessus/nessusd.conf is created, I figured that was ok.

    I've never edited/altered nessusd.conf before, so it might be possible to alter nessusd behavior to not insist on certificates.

    Throughout, it seems like there's a chance I'll find something is unable to write due to read/write permissions limitations (I've found several X-based utilities that don't like everything being owned by root, when I try to save files).

  2. #2
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    Auckland, New Zealand
    Posts
    818
    there is a "start nessus" menu option in the kde knoppix menu, you probally have to use that as it may start nessusd with some special options.

  3. #3
    Junior Member
    Join Date
    Jan 2003
    Location
    San Francisco
    Posts
    2
    nessus-mkcert normally updates the /etc/nessus/nessusd.conf file. On Knoppix, this is a symlink to the KNOPPIX loopback on the CD-ROM, so nessusd.conf is readonly. The nessus-mkcert program cannot update the conf file, but does not report the error.

    You can delete the symlink, manually copy the KNOPPIX/etc/nessus/ version of the file, then run nessus-mkcert. This will work.

    There is also a 'Start Nessus' menu item under the KDE system on Knoppix. It probably automates these steps - I haven't yet used this.

  4. #4
    Member registered user
    Join Date
    Dec 2002
    Location
    Thousand Oaks, CA
    Posts
    96
    Nessus does run from the CD if started from the KDE...System...Security menu. Use a user name of knoppix and a password of knoppix. It worked for me, though it seemed slower than usual at scanning.

Similar Threads

  1. problem with nessus
    By happyholger in forum Networking
    Replies: 0
    Last Post: 10-12-2003, 12:28 PM
  2. need help with nessus
    By happyholger in forum Customising & Remastering
    Replies: 0
    Last Post: 10-03-2003, 05:31 PM
  3. Nessus plugins, again....
    By jafo in forum General Support
    Replies: 0
    Last Post: 04-27-2003, 11:24 AM
  4. Nessus plugins
    By timix in forum General Support
    Replies: 2
    Last Post: 04-16-2003, 07:04 PM
  5. Nessus startup
    By s3nt3nza in forum General Support
    Replies: 4
    Last Post: 04-12-2003, 02:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Gigabyte 4U AI Server 10x Nvidia GPU 2x Xeon Gold 6150 36 Core 2.7GHz DDR4 RAM picture

Gigabyte 4U AI Server 10x Nvidia GPU 2x Xeon Gold 6150 36 Core 2.7GHz DDR4 RAM

$1625.00



Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram  2x 550W PSU No HDD picture

Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD

$275.00



Microsoft Windows Server 2025 Standard 64Bit 16 Core-50 CALs DVD With Key Sealed picture

Microsoft Windows Server 2025 Standard 64Bit 16 Core-50 CALs DVD With Key Sealed

$49.99



867959-B21 HPE ProLiant DL360 G10 CTO Server W/ 2x 865414-B21 1x 840140-001 picture

867959-B21 HPE ProLiant DL360 G10 CTO Server W/ 2x 865414-B21 1x 840140-001

$245.00



Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W picture

Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W

$409.99



Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p picture

Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p

$499.88



Dell PowerEdge R730XD 28 Core Server 2X Xeon E5-2680 V4 H730 32GB RAM No HDD picture

Dell PowerEdge R730XD 28 Core Server 2X Xeon E5-2680 V4 H730 32GB RAM No HDD

$378.93



Dell Poweredge R730xd 12LFF 2*2660v4 4*1Gbe h730 2x 750W Server CTO picture

Dell Poweredge R730xd 12LFF 2*2660v4 4*1Gbe h730 2x 750W Server CTO

$308.00



Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Core | HBA330 | No RAM or HDD picture

Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Core | HBA330 | No RAM or HDD

$149.99



Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb picture

Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb

$374.99