nessus-mkcert normally updates the /etc/nessus/nessusd.conf file. On Knoppix, this is a symlink to the KNOPPIX loopback on the CD-ROM, so nessusd.conf is readonly. The nessus-mkcert program cannot update the conf file, but does not report the error.

You can delete the symlink, manually copy the KNOPPIX/etc/nessus/ version of the file, then run nessus-mkcert. This will work.

There is also a 'Start Nessus' menu item under the KDE system on Knoppix. It probably automates these steps - I haven't yet used this.