-
Cannot Mount root FS scsi issues
I am able to load knoppix with 2.4.22. I need to load my scsi module to get the scsi system working. Once I had that working, I installed the OS to the hd. It's installed to /sda and I see all the files.
It will not load the scsi module now during the normal boot. This is to be expected since the scsi module isn't loaded into the kernel. THe module I am using is aic79xx. How can I get this loaded into the kernel?
Shoul I download the kernel source (2.4.22) and adding in that module. If so I might be a little sketchy on how to do that.
-
Well, at this point we downloaded the kernel source, and compiled with the support necessary.
Now LILO is giving me issues with the IDE scsi, and during the
boot i get:
VFS: Connaot open root decive "803"
Please appent a correct "root=" boot option
Kernel Panic : VFS : Unable to mount root fs
-
Senior Member
registered user
o Boot Knoppix CD to runlevel 2
o ' fdisk -l ; df ' == Make sure your intended root partition is detected and mounted
o ' mount /mnt/sda1 -oremount,rw ' == Or whatever the root partition is
o ' chroot /mnt/sda1 '
--Edit /etc/lilo.conf (as root) and change the "boot=" to /dev/sdaX (wherever you want to install the boot loader; or /dev/sda if you want to use Lilo as the MBR) and the "root=" to /dev/sdaX, wherever the root partition is.
--Then run ' lilo -v 1 ' and check that it says "Writing boot sector." Ctrl-D to get out of the chroot, and ' reboot '.
--Double check the SCSI adapter is configured to boot before IDE.
--Post back with results.

Originally Posted by
veitcha
Well, at this point we downloaded the kernel source, and compiled with the support necessary.
Now LILO is giving me issues with the IDE scsi, and during the
boot i get:
VFS: Connaot open root decive "803"
Please appent a correct "root=" boot option
Kernel Panic : VFS : Unable to mount root fs
-

Originally Posted by
Dave_Bechtel
--Post back with results.
Ok, so it now boots, somewhat. It will load the scsi driver, and begin to check the HD. It fails and says :
"Checking root file system....
fsck 1.34-WIP (21-May-2003)
Failed to open the filesystem
...<long warning>
Warning.. fsck.reiserfs for decive /dev/sda3 exited with signal 6.
fsck failed. Please repair ......
"
it suggests "# mount -n -o remount,rw /"
we try that, it works, then we try fsck.reiserfs --rebuild-sb /dev/sda3
[yes]
super.c 309 rebuild_sb
rebuils_sb: cannot open device /dev/sda3
does this mean it's still not seeing it right? ?
here is a copy of lilo.conf
"
boo=/dev/sda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
lba32
default=linux
image=/boot/bzImage
label=linux
read-only
rooot=/dev/sda3
Any suggestions?
Thanks for the input so far. At least it's booting by itself and loads the scsi module.
-
Senior Member
registered user
--Reinstall Knoppix. It's better than trying to deal with a bad fsck unless there's critical, un-backed-up data on the filesystem.
--I *hope* that's not your real lilo.conf, it has some spelling errors! You're better off doing cut-n-paste.
It should be:
Code:
boot=/dev/sda
root=/dev/sda3
--Since this is a scsi drive, try taking out the LBA32 entry as well. That's just a guess tho.
--After the reinstall is up and working with the stock kernel, *BACK IT UP*, then do the kernel compile/upgrade. If you compile reiserfs into the kernel rather than as module, make sure lilo.conf doesn't point to the initrd for that kernel entry.

Originally Posted by
veitcha

Originally Posted by
Dave_Bechtel
--Post back with results.
Ok, so it now boots, somewhat. It will load the scsi driver, and begin to check the HD. It fails and says :
"Checking root file system....
fsck 1.34-WIP (21-May-2003)
Failed to open the filesystem
...<long warning>
Warning.. fsck.reiserfs for decive /dev/sda3 exited with signal 6.
fsck failed. Please repair ......
"
it suggests "# mount -n -o remount,rw /"
we try that, it works, then we try fsck.reiserfs --rebuild-sb /dev/sda3
[yes]
super.c 309 rebuild_sb
rebuils_sb: cannot open device /dev/sda3
does this mean it's still not seeing it right? ?
here is a copy of lilo.conf
"
boo=/dev/sda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
lba32
default=linux
image=/boot/bzImage
label=linux
read-only
rooot=/dev/sda3
Any suggestions?
Thanks for the input so far. At least it's booting by itself and loads the scsi module.
Similar Threads
-
By helkyd in forum Hardware & Booting
Replies: 1
Last Post: 05-14-2004, 02:19 PM
-
By biohazard in forum Hdd Install / Debian / Apt
Replies: 2
Last Post: 12-26-2003, 02:55 AM
-
By ullmanns in forum Hdd Install / Debian / Apt
Replies: 0
Last Post: 07-08-2003, 03:51 PM
-
By ventallo in forum Hdd Install / Debian / Apt
Replies: 11
Last Post: 05-16-2003, 07:35 PM
-
By Tony Magon in forum General Support
Replies: 1
Last Post: 02-26-2003, 06:01 PM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

SK Hynix 1TB PC801 M.2 NVMe PCIe Gen4x4 2280 SSD
$100.00

Samsung 2.5" 870 EVO SSD SATA III 250GB 500GB 1TB Internet Solid State Drive Lot
$60.00

External SSD 1TB 2TB 4TB Portable Hard Drive USB 3.0 Type-C High Speed PC Mac
$19.99

Dell Latitude 14" Laptop Computer Intel i5 Up To 32GB RAM 1TB SSD Windows 11 Pro
$545.25

1TB Kingston DataTraveler Max DTMAX/1TB USB Type-C Flash Drive
$86.95

SAMSUNG T7 Portable SSD 1TB Indigo Blue USB 3.2 Gen2 External MU-PC1T0H/AM
$159.99

Crucial MX500 1TB 2.5" SATA III Internal SSD CT1000MX500SSD1
$99.99

Acer Predator Helios Neo 16S AI 16" i9 275HX 2S RTX 5070 Ti 32GB 1TB SSD Refurb
$1746.47

Dell Latitude 14" Laptop Computer Intel i7 Up To 32GB RAM 1TB SSD Windows 11 Pro
$330.73

External Solid State Drive USB 3.2 Gen2, 1TB SSD External Hard Drive with C to A
$100.00