Results 1 to 5 of 5

Thread: Cannot Mount root FS scsi issues

Hybrid View

  1. #1
    Junior Member
    Join Date
    Sep 2003
    Posts
    4

    Cannot Mount root FS scsi issues

    I am able to load knoppix with 2.4.22. I need to load my scsi module to get the scsi system working. Once I had that working, I installed the OS to the hd. It's installed to /sda and I see all the files.

    It will not load the scsi module now during the normal boot. This is to be expected since the scsi module isn't loaded into the kernel. THe module I am using is aic79xx. How can I get this loaded into the kernel?


    Shoul I download the kernel source (2.4.22) and adding in that module. If so I might be a little sketchy on how to do that.

  2. #2
    Junior Member
    Join Date
    Sep 2003
    Posts
    4
    Well, at this point we downloaded the kernel source, and compiled with the support necessary.

    Now LILO is giving me issues with the IDE scsi, and during the
    boot i get:
    VFS: Connaot open root decive "803"
    Please appent a correct "root=" boot option
    Kernel Panic : VFS : Unable to mount root fs

  3. #3
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    USA, IL
    Posts
    1,041
    o Boot Knoppix CD to runlevel 2
    o ' fdisk -l ; df ' == Make sure your intended root partition is detected and mounted
    o ' mount /mnt/sda1 -oremount,rw ' == Or whatever the root partition is
    o ' chroot /mnt/sda1 '

    --Edit /etc/lilo.conf (as root) and change the "boot=" to /dev/sdaX (wherever you want to install the boot loader; or /dev/sda if you want to use Lilo as the MBR) and the "root=" to /dev/sdaX, wherever the root partition is.

    --Then run ' lilo -v 1 ' and check that it says "Writing boot sector." Ctrl-D to get out of the chroot, and ' reboot '.

    --Double check the SCSI adapter is configured to boot before IDE.

    --Post back with results.

    Quote Originally Posted by veitcha
    Well, at this point we downloaded the kernel source, and compiled with the support necessary.

    Now LILO is giving me issues with the IDE scsi, and during the
    boot i get:
    VFS: Connaot open root decive "803"
    Please appent a correct "root=" boot option
    Kernel Panic : VFS : Unable to mount root fs

  4. #4
    Junior Member
    Join Date
    Sep 2003
    Posts
    4
    Quote Originally Posted by Dave_Bechtel
    --Post back with results.

    Ok, so it now boots, somewhat. It will load the scsi driver, and begin to check the HD. It fails and says :
    "Checking root file system....
    fsck 1.34-WIP (21-May-2003)
    Failed to open the filesystem
    ...<long warning>
    Warning.. fsck.reiserfs for decive /dev/sda3 exited with signal 6.
    fsck failed. Please repair ......
    "
    it suggests "# mount -n -o remount,rw /"
    we try that, it works, then we try fsck.reiserfs --rebuild-sb /dev/sda3

    [yes]
    super.c 309 rebuild_sb
    rebuils_sb: cannot open device /dev/sda3

    does this mean it's still not seeing it right? ?

    here is a copy of lilo.conf
    "
    boo=/dev/sda
    map=/boot/map
    install=/boot/boot.b
    prompt
    timeout=50
    lba32
    default=linux

    image=/boot/bzImage
    label=linux
    read-only
    rooot=/dev/sda3


    Any suggestions?
    Thanks for the input so far. At least it's booting by itself and loads the scsi module.

  5. #5
    Senior Member registered user
    Join Date
    Nov 2002
    Location
    USA, IL
    Posts
    1,041
    --Reinstall Knoppix. It's better than trying to deal with a bad fsck unless there's critical, un-backed-up data on the filesystem.

    --I *hope* that's not your real lilo.conf, it has some spelling errors! You're better off doing cut-n-paste.

    It should be:
    Code:
      boot=/dev/sda
               root=/dev/sda3
    --Since this is a scsi drive, try taking out the LBA32 entry as well. That's just a guess tho.

    --After the reinstall is up and working with the stock kernel, *BACK IT UP*, then do the kernel compile/upgrade. If you compile reiserfs into the kernel rather than as module, make sure lilo.conf doesn't point to the initrd for that kernel entry.

    Quote Originally Posted by veitcha
    Quote Originally Posted by Dave_Bechtel
    --Post back with results.

    Ok, so it now boots, somewhat. It will load the scsi driver, and begin to check the HD. It fails and says :
    "Checking root file system....
    fsck 1.34-WIP (21-May-2003)
    Failed to open the filesystem
    ...<long warning>
    Warning.. fsck.reiserfs for decive /dev/sda3 exited with signal 6.
    fsck failed. Please repair ......
    "
    it suggests "# mount -n -o remount,rw /"
    we try that, it works, then we try fsck.reiserfs --rebuild-sb /dev/sda3

    [yes]
    super.c 309 rebuild_sb
    rebuils_sb: cannot open device /dev/sda3

    does this mean it's still not seeing it right? ?

    here is a copy of lilo.conf
    "
    boo=/dev/sda
    map=/boot/map
    install=/boot/boot.b
    prompt
    timeout=50
    lba32
    default=linux

    image=/boot/bzImage
    label=linux
    read-only
    rooot=/dev/sda3


    Any suggestions?
    Thanks for the input so far. At least it's booting by itself and loads the scsi module.

Similar Threads

  1. Kernel Panic: VFS: Unable to mount root fs on 21:02
    By helkyd in forum Hardware & Booting
    Replies: 1
    Last Post: 05-14-2004, 02:19 PM
  2. Kernel panic: VFS : Unable to mount root fs on 03:02
    By biohazard in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 12-26-2003, 02:55 AM
  3. Kernel Panic: Cannot mount root-fs (SCSI driver missing)
    By ullmanns in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 07-08-2003, 03:51 PM
  4. kernel panic:VFS:unable to mount root fs on 08:03
    By ventallo in forum Hdd Install / Debian / Apt
    Replies: 11
    Last Post: 05-16-2003, 07:35 PM
  5. Newbie Problem - Unable to mount root fs on 01:01 etc
    By Tony Magon in forum General Support
    Replies: 1
    Last Post: 02-26-2003, 06:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


SFP TO RJ45 TRANSCEIVER SFP MODULE COPPER SFP OPTICAL PORT TO RJ45 ETHERNET PORT picture

SFP TO RJ45 TRANSCEIVER SFP MODULE COPPER SFP OPTICAL PORT TO RJ45 ETHERNET PORT

$7.99



NEW Sealed Cisco SFP-10G-LR 10GBASE-LR SFP+ 1310nm 10km *US Shipping* picture

NEW Sealed Cisco SFP-10G-LR 10GBASE-LR SFP+ 1310nm 10km *US Shipping*

$24.00



Cisco Acacia DP04QSDD-E25-840 400G QSFP-DD Coherent DCO Transceiver Module picture

Cisco Acacia DP04QSDD-E25-840 400G QSFP-DD Coherent DCO Transceiver Module

$699.99



Arista SFP-10G-SR 10GBASE-SR XVR-10001-20 850nm SFP+ Optical Transceiver picture

Arista SFP-10G-SR 10GBASE-SR XVR-10001-20 850nm SFP+ Optical Transceiver

$30.00



Genuine Cisco SFP-10G-SR 0-2415-03 10 Gigabit Transceiver picture

Genuine Cisco SFP-10G-SR 0-2415-03 10 Gigabit Transceiver

$5.40



HP 560SFP+ 10GB 2-port  PCIe NIC Ethernet ADAPTER 669279-001 w/ (2) 10GB SFP+ picture

HP 560SFP+ 10GB 2-port PCIe NIC Ethernet ADAPTER 669279-001 w/ (2) 10GB SFP+

$16.99



Intel X520-DA2 10Gb 10Gbe 10 Gigabit Network Adapter NIC Dual Port E10G42BTDA picture

Intel X520-DA2 10Gb 10Gbe 10 Gigabit Network Adapter NIC Dual Port E10G42BTDA

$28.94



Lenovo 00YK615 Intel X710-DA2 10GbE 2-port SFP+ PCI-E FC Network Adapter NIC picture

Lenovo 00YK615 Intel X710-DA2 10GbE 2-port SFP+ PCI-E FC Network Adapter NIC

$27.99



Dell 10 Gigabit SFP+ SR Transceiver 0XYD50 NEW SEALED picture

Dell 10 Gigabit SFP+ SR Transceiver 0XYD50 NEW SEALED

$24.99



Dell Mellanox ConnectX-4 Lx CX4121C 020NJD Dual-Port 25GbE SFP28 NIC Low Profile picture

Dell Mellanox ConnectX-4 Lx CX4121C 020NJD Dual-Port 25GbE SFP28 NIC Low Profile

$35.00