I don't this is the forum to discuss the issue. However, I'd like to add my two bits from my own experience yesterday.

I installed Knoppix (Debian) on the hard disk and I faced this problem too, but here's the confusing part. The problem surfaced only when I used a single 512 MB RAM chip. The problem went away when I switched it with a 128 MB RAM chip.

Note: The problem does not appear when I run Knoppix Live on the CD with 128 or 512 MB RAM.

Weird huh!

Worst part... the damn thing works fine on Red Hat 9.

So I was unable to use Knoppix since I ran out of time.

Regards

Rishi