Results 1 to 7 of 7

Thread: Can't mount any HDD partitions

  1. #1
    Junior Member registered user
    Join Date
    Oct 2003
    Posts
    20

    Can't mount any HDD partitions

    Hi, I just fired up Knoppix 3.3 for the first time. It works really well, except that I can't mount anything. It autodetects that I have 4 partitions, but when I try to mount them with KDE it says "Could not mount device.
    The reported error was:
    mount: I could not determine the filesystem type, and none was specified". I tried "mount -t vfat /dev/hda1 /mnt/hda1" and "mount -t reiserfs /dev/hda2 /mnt/hda2" and it always says mount: wrong fs type, bad option, bad superblock on /dev/hda2, or too many mounted file systems". When I run qtparted as root, it says in the terminal "Error: Unable to open /dev/hda - unrecognised disk label." Any ideas? Thank you!

  2. #2
    Junior Member registered user
    Join Date
    Sep 2003
    Posts
    10
    I use the commnad "mount /dev/hda2 /mnt/hda2" to mount partitions.

  3. #3
    Junior Member registered user
    Join Date
    Oct 2003
    Posts
    20
    BTW, I have an old IDE harddrive. When I first boot Knoppix, it says "ldm_validate_partition_table(); Disk read failed". I'm pretty sure that's the problem. However, my disk works fine with Windows, Redhat, Mandrake, SuSE Live-Eval, and anything else I use. But Knoppix still figured out my partition table enough to create dekstop icons for /dev/hda1, 2, 3, and 4. I just can't mount them. Is my HDD not detected correctly? It looks like the controller is SiS 5513 dual pci (dual fifo), according to Windows. Any idea how to load a specific controller module at boot time? Thanks!

  4. #4
    Junior Member registered user
    Join Date
    Oct 2003
    Posts
    20
    I'm pretty sure this is a Knoppix bug. fdisk /dev/hda in knoppix says there is no partition table. In Redhat 9, there is no problem with partition tables. Any suggestions? Should I file a bug report somewhere? Thanks!

  5. #5
    Junior Member
    Join Date
    Sep 2003
    Posts
    4
    I encounter this problem also when i want to install knoppix on my HD.
    I use qtparted to partition the disk which contains only 1 primary partition with windows98 (fat32).
    When i havestarted knoppix WITHOUT dma it gives the same "error: Unable to open /dev/hda - unrecognised disk label" and then it just quits but sometimes it just wants to wipe the entire disk because it doesn't detect the fat32 primary partition. Very puzzeling...
    But when i start knoppix WITH the parameter 'DMA' is different. I can now run qtparted (allthough the error is still produced but qtparted now doesn't quit) and i can partition my hd (still with some minor error messages but i think that's something else with qtparted "bad window" or something).

    The harddisk is also rather old, it's a Seagate ST320430A of 20 GB capacity.
    And the mobo is a ECS P6SET-ML with a SIS620/5595 chipset
    link

    I also experience the same problem as described here but with the suggested commandos it is fixed. I don't know if it is related to the the qtparted problem...

    The strange thing is with Partition Magic 8.0 there are no erros whatsoever detected so what's the problem??[/url]

  6. #6
    Junior Member
    Join Date
    Feb 2004
    Posts
    2
    I had the same error (and qtparted just dies) on a brand new ECS 661FX-M board with new Western Digital WD400PB drive.

    I ran the Microsoft FDISK, created a partition, rebooted Knoppix and then qtparted was happy. I've not done any more than that, though.

    Bob Long

  7. #7
    Junior Member
    Join Date
    Feb 2004
    Posts
    2
    A followup: I ran FDISK again, deleted the partition, booted Knoppix, and qtparted did not complain. I did not actually try to create a partition, as the drive is to be "bare" when going to the customer.

    Bob Long
    (PS: I'm using Knoppix to test - to some extent - newly assembled systems that go to the customer without an operating system. It's great!)

Similar Threads

  1. Unable to mount NTFS partitions
    By Tenfjord in forum General Support
    Replies: 3
    Last Post: 06-27-2005, 05:41 AM
  2. Mount all partitions automatically
    By muczy in forum General Support
    Replies: 1
    Last Post: 08-16-2004, 11:50 AM
  3. Cannot mount windows partitions
    By milkjam in forum General Support
    Replies: 4
    Last Post: 07-26-2004, 05:00 AM
  4. partitions don't mount
    By jackren in forum Hdd Install / Debian / Apt
    Replies: 6
    Last Post: 03-24-2004, 02:03 PM
  5. Mount all partitions
    By henrique in forum Customising & Remastering
    Replies: 0
    Last Post: 09-24-2003, 12:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Dell PowerEdge M630 Blade Server 2x Xeon E5-2680 v4, 2F3MP , 4GDP5 ,R10KJ ,JVFVR picture

Dell PowerEdge M630 Blade Server 2x Xeon E5-2680 v4, 2F3MP , 4GDP5 ,R10KJ ,JVFVR

$95.20



Dell PowerEdge M620 Blade Server 2x Xeon E5-2680v2 256GB DDR3 RAM NO HDD picture

Dell PowerEdge M620 Blade Server 2x Xeon E5-2680v2 256GB DDR3 RAM NO HDD

$349.99



Dell PowerEdge M640 Blade Barebone Server Dell P/N: HHB006 Tested Working picture

Dell PowerEdge M640 Blade Barebone Server Dell P/N: HHB006 Tested Working

$149.99



Nutanix Supermicro NXS2U2NL12G600  2x Node with Motherboards, Backplanes, & More picture

Nutanix Supermicro NXS2U2NL12G600 2x Node with Motherboards, Backplanes, & More

$450.00



Supermicro 4U 32x 3.5 Bays 4-Nodes | 8x E5-2660 v3 2.6Ghz | 64gb RAM | 9207-8i picture

Supermicro 4U 32x 3.5 Bays 4-Nodes | 8x E5-2660 v3 2.6Ghz | 64gb RAM | 9207-8i

$699.99



NETAPP HCI NAF-1701 SuperMicro Server 4X BLADE H410C 8X GOLD 5120 4 NODE SERVER picture

NETAPP HCI NAF-1701 SuperMicro Server 4X BLADE H410C 8X GOLD 5120 4 NODE SERVER

$1499.97



Dell Poweredge C6400 24x 2.5’’ 2x 2400W 4x C6420 Nodes H330 | 2x SFP | 8x Trays picture

Dell Poweredge C6400 24x 2.5’’ 2x 2400W 4x C6420 Nodes H330 | 2x SFP | 8x Trays

$799.99



DELL POWEREDGE FC640 Server FHH8V W/×2 Intel Xeon Gold 6142,0KHKN5. *READ⬇* picture

DELL POWEREDGE FC640 Server FHH8V W/×2 Intel Xeon Gold 6142,0KHKN5. *READ⬇*

$130.00



NEW Cisco UCSB-5108-AC2 Blade Server Chassis 8 Slot 6RU Chassis 4 X PSU - DW picture

NEW Cisco UCSB-5108-AC2 Blade Server Chassis 8 Slot 6RU Chassis 4 X PSU - DW

$599.40



ASUS Blade Server LAN Web Remote Management KVM Module Chip IPMI 2.0 ASMB9-iKVM picture

ASUS Blade Server LAN Web Remote Management KVM Module Chip IPMI 2.0 ASMB9-iKVM

$49.99