Nessus (local client, local server) seems to fail. I'll keep looking at it, but here's what I know:

Using the 1.1.03 version (3.1?) of Knoppix-EN.

When I run 'nessusd -D', Nessus complains about a certificate:
*** 'ca_file' is not set - did you run nessus-mkcert ?

According to msgs on google, this was due to a bad RPM, and getting a new/fixed RPM solved the problem.

Has anyone had better luck with this? So far, I have:

Attempted to apt-get install nessusd, since I know debian better than RPM's (Linux's answer to .dll hell): apt-get Result wasn't pretty. Uglier still when I did an apt-get update.

running nessus-mkcert did have one error in the midst of it:
------------------------ snip
Congratulations. Your server certificate was properly created.

mv: cannot stat `/etc/nessus/nessusd.conf.tmp': No such file or directory
/etc/nessus/nessusd.conf updated

The following files were created :

. Certification authority :
Certificate = /var/lib/nessus/CA/cacert.pem
Private key = /var/lib/nessus/private/CA/cakey.pem

. Nessus Server :
Certificate = /var/lib/nessus/CA/servercert.pem
Private key = /var/lib/nessus/private/CA/serverkey.pem
--------------------- end snip
... but since /etc/nessus/nessusd.conf is created, I figured that was ok.

I've never edited/altered nessusd.conf before, so it might be possible to alter nessusd behavior to not insist on certificates.

Throughout, it seems like there's a chance I'll find something is unable to write due to read/write permissions limitations (I've found several X-based utilities that don't like everything being owned by root, when I try to save files).