-
Nessus fails
Nessus (local client, local server) seems to fail. I'll keep looking at it, but here's what I know:
Using the 1.1.03 version (3.1?) of Knoppix-EN.
When I run 'nessusd -D', Nessus complains about a certificate:
*** 'ca_file' is not set - did you run nessus-mkcert ?
According to msgs on google, this was due to a bad RPM, and getting a new/fixed RPM solved the problem.
Has anyone had better luck with this? So far, I have:
Attempted to apt-get install nessusd, since I know debian better than RPM's (Linux's answer to .dll hell): apt-get Result wasn't pretty. Uglier still when I did an apt-get update.
running nessus-mkcert did have one error in the midst of it:
------------------------ snip
Congratulations. Your server certificate was properly created.
mv: cannot stat `/etc/nessus/nessusd.conf.tmp': No such file or directory
/etc/nessus/nessusd.conf updated
The following files were created :
. Certification authority :
Certificate = /var/lib/nessus/CA/cacert.pem
Private key = /var/lib/nessus/private/CA/cakey.pem
. Nessus Server :
Certificate = /var/lib/nessus/CA/servercert.pem
Private key = /var/lib/nessus/private/CA/serverkey.pem
--------------------- end snip
... but since /etc/nessus/nessusd.conf is created, I figured that was ok.
I've never edited/altered nessusd.conf before, so it might be possible to alter nessusd behavior to not insist on certificates.
Throughout, it seems like there's a chance I'll find something is unable to write due to read/write permissions limitations (I've found several X-based utilities that don't like everything being owned by root, when I try to save files).
-
Senior Member
registered user
there is a "start nessus" menu option in the kde knoppix menu, you probally have to use that as it may start nessusd with some special options.
-
nessus-mkcert normally updates the /etc/nessus/nessusd.conf file. On Knoppix, this is a symlink to the KNOPPIX loopback on the CD-ROM, so nessusd.conf is readonly. The nessus-mkcert program cannot update the conf file, but does not report the error.
You can delete the symlink, manually copy the KNOPPIX/etc/nessus/ version of the file, then run nessus-mkcert. This will work.
There is also a 'Start Nessus' menu item under the KDE system on Knoppix. It probably automates these steps - I haven't yet used this.
-
Nessus does run from the CD if started from the KDE...System...Security menu. Use a user name of knoppix and a password of knoppix. It worked for me, though it seemed slower than usual at scanning.
Similar Threads
-
By happyholger in forum Networking
Replies: 0
Last Post: 10-12-2003, 12:28 PM
-
By happyholger in forum Customising & Remastering
Replies: 0
Last Post: 10-03-2003, 05:31 PM
-
By jafo in forum General Support
Replies: 0
Last Post: 04-27-2003, 11:24 AM
-
By timix in forum General Support
Replies: 2
Last Post: 04-16-2003, 07:04 PM
-
By s3nt3nza in forum General Support
Replies: 4
Last Post: 04-12-2003, 02:47 AM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

Novell SUSE Linux Enterprise Server 9, Linux Professional 8.2 / 9.1 — 3 DVD Set
$58.00

Ubuntu Server 26.04.1 LTS Bootable USB Flash Drive – Latest September 2026
$12.99

OPNsense Firewall VPN QAT 8-Core Atom C3758 2.20GHz 16GB DDR4 128GB SSD 8xNIC
$175.00

RED HAT ENTERPRISE LINUX 5 SERVER RHF0382US-R1 for PC x86 AMD 64 INTEL 64 30 Day
$188.24

OPNsense pfSense 8-Core Atom C3758 2.2GHz 8GB DDR4 64GB SSD 8x NIC QAT AES VPN
$115.00

All New Ubuntu 26.04 LTS Linux Bootable USB Flash Drive
$15.95

1U Rackmount PC Intel Core i5-2520M 8GB RAM 500GB HDD Ubuntu Linux Server
$109.99

Microsoft SQL Server 2019 Enterprise 40 Core Unlimited CAL Retail License FPP
$299.00

Sun Enterprise e450 400mhz cpu(x4), 4gb ram, 9gb HD w/spud most complete on ebay
$500.00

SQL Server 2022 Enterprise 96 Core License & DVD Unlimited CALs with CoA
$284.99