Quote Originally Posted by A. Jorge Garcia
Quote Originally Posted by Anonymous
I've solved some of my problem. I got sudo to work, which gives me the functionality I need, but I still am having problems getting su to work.

PAM still gives me:

authentication failure; knewuser (uid=1001) -> root for su service
What did you do to get sudo to work?

Regards,
http://www.courtesan.com/sudo/man/sudoers.html

Check the sudoers file and make sure that the user can su.