Hi,
me again. I think i found the problem. It seems like kernel 2.6 isnt recognizing the LBA sectro numbers correctly. It sais i got only 234388333. But in fact there are 234441648 ogf them.
Can this problem be solved somehow?
I am using kernel 2.6.1 with the mm5 patch, a western digital 1200jb (120 gb) and ext3 as filesystem.
Now my problem is that when i'm working in Linux i suddenly get the error that the filesystem is read-only. A look into the log messages says:
dma_intr: error=0x10 { SectorIdNotFound}, LBAsect=234388333.
That sector number does not tell me anything.
But it seems that linux remounts the filesystem as read-only if an error occurs. Please correct me if i am wrong with that part.
Under kernel 2.4 i never had such an problem.
PLease help me.
I would really like to use 2.6
thx
Hi,
me again. I think i found the problem. It seems like kernel 2.6 isnt recognizing the LBA sectro numbers correctly. It sais i got only 234388333. But in fact there are 234441648 ogf them.
Can this problem be solved somehow?
I think you may have found a bug I am using the -mm4 patch here on my test partition and it gets detected properly.Originally Posted by debi
So you may want to drop back to the -mm4 and see if you get the same behavior. Oh I use reiserfs on the drive but that should make no difference.Code:hda: WDC WD1200JB-32EVA0, ATA DISK drive hdb: MAXTOR 4K040H2, ATA DISK drive ide0 at 0x1f0-0x1f7,0x3f6 on irq 14 hdc: IRQ probe failed (0xffffbeba) hdc: HL-DT-ST DVDRAM GSA-4040B, ATAPI CD/DVD-ROM drive ide1 at 0x170-0x177,0x376 on irq 15 hda: max request size: 1024KiB hda: 234441648 sectors (120034 MB) w/8192KiB Cache, CHS=16383/255/63, UDMA(100) hda: hda1 hda2 hda3 hda4 < hda5 hda6 > hdb: max request size: 128KiB hdb: 78198750 sectors (40037 MB) w/2000KiB Cache, CHS=65535/16/63, UDMA(100) hdb: hdb1 hdb2 hdb3 hdb4 ide-floppy driver 0.99.newide ide-scsi is deprecated for cd burning! Use ide-cd and give dev=/dev/hdX as device scsi0 : SCSI host adapter emulation for IDE ATAPI devices Vendor: HL-DT-ST Model: DVDRAM GSA-4040B Rev: A104 Type: CD-ROM ANSI SCSI revision: 02 [06:43 PM Sat Jan 24: stephen @ ~] >$ uname -a Linux HappyTux 2.6.1-mm4.040119 #1 Mon Jan 19 03:21:10 AST 2004 i686 GNU/Linux
hda: Host Protected Area detected.
current capacity is 234375000 sectors (120000 MB)
native capacity is 234441648 sectors (120034 MB)
hda: 234375000 sectors (120000 MB) w/8192KiB Cache, CHS=65535/16/63
What does this "Host Protected Area decteted" mean?
I tried it already without any mm patch. The same problem.

(New) AMD Ryzen 7 5700X 8 Core 16 Thread AM4 Unlocked 3.4 GHz CPU OEM Tray
$174.99
Pair ID-COOLING A8-SP3 CPU Heatsink Coolers and AMD EPYC 7601 32 Core Processors
$290.00
AMD Ryzen 7 PRO 8700GE 8-Core/16-Thread Up to 5.1GHz AM5 (FL1)
$189.00
SGIN 17.3" Laptop Intel Quad-Core Up to 2.4 GHZ 8GB RAM 256GB SSD HD
$229.99
AMD Ryzen 7 7800X3D 4.20GHz Quad Core 100-000000510 8 Thread AM4
$279.99
AMD Ryzen 7 9800X3D 8-Core 16-Thread AM5 Zen 5 Desktop Processor NEW
$399.00
Apple Macbook Pro 13" M1 8-Core 16GB 512GB - Good
$464.99
Intel Xeon E5 - 2667V2 / SR19W 3.30GHz 25MB 8-Core CPU Socket LGA2011
$30.00
Dell OptiPlex 5070 SFF i7-9700 (8-Core) 3.0GHz 16GB 256 SSD Windows 11
$250.00
Dell T7810 Workstation 8-Core 2.40GHz E5-2630 v3 No RAM GPU HDD OS
$259.98