Results 1 to 3 of 3

Thread: Problems starting X on remastered Knoppix

  1. #1
    Junior Member
    Join Date
    Jan 2004
    Location
    Germany
    Posts
    2

    Problems starting X on remastered Knoppix

    I have build a remastered knoppix-cd by copying the original files to the harddrive and then running chroot, Xnest and startkde as described at http://www.stirnimann.com/mystuff/doc/knoppix.txt (chapter 3c). But testing the CD I get the following error message:

    • X-window session terminated with errors.
      please check and retry '/etc/init.d/xsession start'


    I thought that startkde in my nested (chroot'ed) environment had changed some configurations, so deleted all X and KDE configuration files and copyed the original ones to the remastered knoppix. But that did not help and I keep getting the same error. There seems to be a problem with the following line of code in /etc/init.d/xsession:

    Code:
    su -c "DISPLAY=:0 exec /etc/X11/xinit/xinitrc" - $USER >/dev/null 2>&1
    When I delete ">/dev/null" here and retry "/etc/init.d/xsession start", I get the following error message:

    • su: Authentication service cannot retrieve authentication info
      (ignored)
      setgid: opperation not permitted


    (where the last line is translated from German so it might differ from the exact english wording)

    Can anyone help me and give me a hint how to fix this error? I've been working on this for hours without success.

    Thanks a lot.

  2. #2
    Senior Member registered user
    Join Date
    Jun 2003
    Posts
    611
    Have you copied /etc/skel into /home/knoppix already? And chmodded and choiwned the files in /home/knoppix?

    Have you made a /home/knoppix/.xinitrc file that contains the text-

    startkde

    ?

    try these things and then su knoppix and start x in your chroot/xnnest environment-

    PS-0 It's usually easier to boot with the cheatocde knoppix 2 and create knoppix's home from /etc/skel and startx without needing to xnest.

  3. #3
    Junior Member
    Join Date
    Jan 2004
    Location
    Germany
    Posts
    2
    Thank you very much for your help, but I still have problems.

    Quote Originally Posted by arkaine23
    Have you copied /etc/skel into /home/knoppix already? And chmodded and choiwned the files in /home/knoppix?

    Have you made a /home/knoppix/.xinitrc file [...]
    I've tried all this now and built a new Knoppix-CD, but this did not help.

    Quote Originally Posted by arkaine23
    try these things and then su knoppix and start x in your chroot/xnnest environment-
    The problem is that I can't su. I tried "su" and got the message:
    Code:
    sudo: can't stat /etc/sudoers No such such file or directory
    sendmail: [761] setgroups() failed: Operation not permitted
    And after creating the file /etc/sudoers (chmod 0440) with the contents below I get the same error as quoted in my first posting.
    Code:
    root     ALL = (ALL) ALL
    knoppix  ALL = (ALL) ALL
    An interesting thing is that though I am able to su in my normal environment (Debian woody), I can't su after chrooting to the Knoppix-source:
    Code:
    sudo: unable to lookup <my machine's name> via gethostbyname()
    sendmail: [641] setgroups() failed: Operation not permitted
    sudo: can't stat /etc/sudoers: No such file or directory
    sendmail: [642] setgroups() failed: Operation not permitted
    Quote Originally Posted by arkaine23
    PS-0 It's usually easier to boot with the cheatocde knoppix 2 and create knoppix's home from /etc/skel and startx without needing to xnest.
    I've tried this but this did not work either. The KDE-startup-screen appeared but after some steps (varying) the system hanged and I had to kill the session with ctrl+alt+backspace.

Similar Threads

  1. problems starting Client with Terminal server
    By wurm in forum Networking
    Replies: 1
    Last Post: 11-12-2004, 03:04 PM
  2. Help, problems starting KDE: No Write Access /home/......
    By Garibaldi in forum General Support
    Replies: 1
    Last Post: 09-11-2004, 04:27 PM
  3. Having problems starting Knoppix...
    By grayfox777 in forum General Support
    Replies: 7
    Last Post: 06-05-2004, 06:54 AM
  4. Problems with running remastered Knoppix :(
    By piom in forum Customising & Remastering
    Replies: 7
    Last Post: 11-17-2003, 10:32 PM
  5. Problems starting knoppix
    By garrettvm in forum General Support
    Replies: 2
    Last Post: 04-17-2003, 04:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


OPNsense pfSense 8-Core Atom C3758 2.2GHz 8GB DDR4 64GB SSD 8x NIC QAT AES VPN picture

OPNsense pfSense 8-Core Atom C3758 2.2GHz 8GB DDR4 64GB SSD 8x NIC QAT AES VPN

$145.00



OPNsense Firewall 16-Core Atom C3958 16GB DDR4 RAM 64GB SSD 8x 1Gbe QAT AES-NI picture

OPNsense Firewall 16-Core Atom C3958 16GB DDR4 RAM 64GB SSD 8x 1Gbe QAT AES-NI

$195.00



Zero Trace Pen: All-in-one Tor Network Anonymous Drive + Cryptocurrency Wallet picture

Zero Trace Pen: All-in-one Tor Network Anonymous Drive + Cryptocurrency Wallet

$147.00



Check Point 1590 Firewall & w builtin WiFI and builtin LTE sim slot picture

Check Point 1590 Firewall & w builtin WiFI and builtin LTE sim slot

$95.99



Fortinet FortiGate 60F FG-60F UTM UTP License Until 2027 Network Security FW VPN picture

Fortinet FortiGate 60F FG-60F UTM UTP License Until 2027 Network Security FW VPN

$229.99



OPNsense pfSense 16-Core Atom C3958 16GB ECC RAM 512GB SSD 8-Port QAT AES-NI VPN picture

OPNsense pfSense 16-Core Atom C3958 16GB ECC RAM 512GB SSD 8-Port QAT AES-NI VPN

$258.00



Fortinet FortiGate 80E 12 Ports Firewall Appliance picture

Fortinet FortiGate 80E 12 Ports Firewall Appliance

$20.25



OPNsense Firewall VPN QAT 8-Core Atom C3758 2.20GHz 16GB DDR4 128GB SSD 8xNIC picture

OPNsense Firewall VPN QAT 8-Core Atom C3758 2.20GHz 16GB DDR4 128GB SSD 8xNIC

$175.00



Unfi Security Gateway Pro picture

Unfi Security Gateway Pro

$170.00



Cisco Meraki MX67-HW Security Appliance Firewall NEW Unused Unclaimed picture

Cisco Meraki MX67-HW Security Appliance Firewall NEW Unused Unclaimed

$202.50