I made a new computer (yay), and proceeded install the Fedora Core. After playing with it for a little while, I thought "No, I don't think so", and did a hard disk install of my trusted knoppix CD (which served me so well in the past).

Everything was fine until reboot time, when it booted into grub, and stayed there. No kernel or os booted, I just got this grub prompt.
It goes into knoppix when I use the boot floppy, but not when it boots from hd. I'm assuming this is because Fedora wrote a boot sector that wasn't deleted by the knoppix install.

I tried looking into fdisk and cfdisk to see if I could wipe the hd and start again, but all the talk of cylinders and partitions confused me. If you write a partition, does it delete all data on the hd?

I also tried uninstalling grub using dselect. I assume that the grub that I uninstalled was a debian grub, not the one that is booting my system.

Is there an easy way to make the hd blank, as new, so that I can install knoppix again? Or a way to make lilo boot instead of this grub thing?