-
Another HD install problem
Ok heres the deal, I have a IBM Netfinity 3000, not the fastest little guy on the planet, but it a durable running little thing. The IBM has a ServeRaid II card in it with 4 x 9GB scsi drives, in a raid 5 configuration, Setup up three partitions with cfdisk, a 4GB for Root, 500MB Swap, Rest went to data storage for a sambe share on the network, and a small intranet webserver, and a mysql database, for our new inventory management program.
I have installed Knoppix V3.3 02-16-2004 to the HD, once the install is done and reboot, I get a kmod failure, will get to the exact error in a second.
Here is a copy of the install messages that you get from running the install from a shell, while booted to the live cd.
root@ttyp0[knoppix]# knx-hdinstall
Setting up /dev/sda3 as swap...
Setting up swapspace version 1, size = 589893 kB
Creating filesystem on /dev/sda1...
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
488640 inodes, 976114 blocks
48805 blocks (5.00%) reserved for the super user
First data block=0
30 block groups
32768 blocks per group, 32768 fragments per group
16288 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736
Writing inode tables: done
Writing superblocks and filesystem accounting information: done
This filesystem will be automatically checked every 31 mounts or
180 days, whichever comes first. Use tune2fs -c or -i to override.
tune2fs 1.35-WIP (31-Jan-2004)
Copying files...ifconfig eth0 192.168.0.1 netmask 255.255.255.0 broadcast 192.168.0.255 up
route add default gw 192.168.0.254
Setting Nameserver in /etc/resolv.conf to 192.168.0.254
Done.
cp: cannot stat `/mnt/target/usr/share/gnome/apps/Knoppix/*': No such file or directory
cp: cannot stat `/etc/alternatives/soffice.*': No such file or directory
1+0 records in
1+0 records out
512 bytes transferred in 0.023634 seconds (21664 bytes/sec)
Setting up boot loader (LILO)...
shell-init: could not get current directory: getcwd: cannot access parent directories: No such file or directory
Added Linux *
Skipping /vmlinuz.old
root@ttyp0[knoppix]#
ok now once I reboot the error meesage that I get is
kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno = 2
VFS: Cannot open root device "801" or 08:01
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:01
as far as what I can tell from the rest of the messages up above these errors I see no problems, but also I do not see anywhere that it is loading the megaraid.o file like it does when booting from the cd.
The quirky thing is that if you boot from cd, you can mount the drives and life is good, the cd sees everythign just perfectly, using the megaraid.o for the ServeRaid II card, but for some reason once installed to the HD, either lilo, or something else is not quite right.
Any help would be greatly appriciated. Thanks!
Linus is the greatest, Love the Knoppix distro!
-
Junior Member
registered user
same thing
I am getting the EXACT same kmod error message, but I am doing an install on my laptop from the gui (kde).
I even made a persistent directory, and downloaded and ran the latest version of the installer (0.3.7 i think). same problem.
the wierd thing is, I have NO SCSI devices on my laptop, as far as I know!!
so, what's going on here?
--sarge
Similar Threads
-
By Droid in forum Hdd Install / Debian / Apt
Replies: 2
Last Post: 11-08-2004, 08:09 AM
-
By gravity in forum Hdd Install / Debian / Apt
Replies: 4
Last Post: 08-22-2004, 04:32 PM
-
By NoviceW in forum Hdd Install / Debian / Apt
Replies: 6
Last Post: 03-23-2004, 07:17 PM
-
By dobell in forum General Support
Replies: 1
Last Post: 01-24-2004, 10:25 PM
-
By jfitie in forum General Support
Replies: 0
Last Post: 11-24-2003, 07:05 PM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

TP-Link TL-SG105 5-Port Gigabit Ethernet Unmanaged Metal Desktop Network Switch
$19.99

Cisco Catalyst 2960-48TT-L 48-Port Fast Ethernet Managed Rackmount Switch
$46.99

NETGEAR GS308EP Essential Series 8-Port Gigabit PoE+ Unmanaged Switch
$49.99

Linksys LGS328MPC 24-Port Managed Gigabit PoE+ Switch with 4 10G SFP+ Uplinks
$224.95

10-Port Gigabit PoE Network Switch with 8 PoE+ Ports with 2 Combo SFP Slots 125W
$39.99

5 Port Gigabit Unmanaged Ethernet Switch, Home Network Hub, Office Ethernet S...
$9.64

TP-Link TL-SG2210P 10-Port Gigabit Smart Switch w/ 8-Port PoE+ NO AC SKU 25597
$36.98

Arista DCS-7010T-48-R 48P 1GbE 4P 10GbE SFP+ RA Switch with rack mounts
$69.00

Cisco WS-C3650-12X48UR-L 48-Port Stackable Layer 3 8x10G SFP+ Port Switch
$129.99

5Ports Gigabit Network Switch w/ 4 PoE+ Ports Total 52W each port 30W Plug&Play
$31.99