Hello again,
Just wanted to let you guys know not to bother with this issue anymore. I finally resolved it by implementing a shell script![]()
--j2
Hello everyone,
I'm using Knoppix to make old pc's and laptops into linux thin terminals which will launch an ICA session.
Here's my problem:
I need the distro installed on the HD to boot directly to a Xsession which will automatically start "wfica" <-- Citrix ICA Linux client
So in essence the machine will look just like a thin terminal.
I have been clawing at this beast for hours trying to figure out this seemingly simple issue. A display manger seem to need to prompt for a login, however I can't allow any kind of linux login prompt because there's already too much things for the user to do. I editect xinitrc to automatically run /usr/lib/ICAClient/wfica . So when I type in "startx" after logging in as root I get the boot to Citrix client look. Which is exactly what I want.
However to get that far I have to log in as root. I need the distro to simply load up and go directly to launching the /usr/lib/ICAClient/wfica binary. I've tried adding /usr/X11R6/bin/startx to the inittab in which case I get a ton of errors. The X server starts but then errors with an "ApplicationServer" not defined or something like that. However after the computer loads and I login as root, I can run startx just fine?
It looks to me like the system doesn't know where the files are, I went ahead and exported a bunch of directories as a test and I got a different set of errors, but it looked like it was partially resolved, but the Xserver still crashed cause of the errors.
Does anyone have an idea of how to get 'startx' to run upon boot without the massive errors?
I played a bit with kdm but I had an error about "wmaker" file could not be opened, and I have the "wmaker" package installed! (I believe I was trying to run icewm as the desktop manager)
I tried adding "local" to /etc/init.d/ with an entry of "exec /usr/X11R6/bin/startx" to no avail as I read up that Debian uses that file as opposed to rc.local
(I'm a Debian noob b.t.w)
Thanks for any help you guys can provide, hopefully by tomarrow!![]()
--j2
Hello again,
Just wanted to let you guys know not to bother with this issue anymore. I finally resolved it by implementing a shell script![]()
--j2

IBM System X3850-X5 Server w/4x Intel Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD
$1299.99
IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM
$179.99
Unused IBM 09P0037 MAINBOARD For RS/6000 7044-170 P-Series
$375.00
Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs
$49.99
IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES
$110.30
IBM 02YC027 Seagate ST2400MM0129 2.4TB 10K SAS 12Gb/s 2.5" Server Hard Drive
$200.00
IBM System x3550 M3 1U Server Intel Xeon E5630 4GB DDR3 No HDD
$279.99
IBM Power 8 S822L Server 8247-22L POWER8 Enterprise 256GB RAM 2x 00KV626 CPU
$999.99
IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon E5620
$199.99
IBM Server Rackmount Sliding Rail Kit ( Part Numbers: 00D9375 / 00D9374 )
$24.99