Hello again,
Just wanted to let you guys know not to bother with this issue anymore. I finally resolved it by implementing a shell script![]()
--j2
Hello everyone,
I'm using Knoppix to make old pc's and laptops into linux thin terminals which will launch an ICA session.
Here's my problem:
I need the distro installed on the HD to boot directly to a Xsession which will automatically start "wfica" <-- Citrix ICA Linux client
So in essence the machine will look just like a thin terminal.
I have been clawing at this beast for hours trying to figure out this seemingly simple issue. A display manger seem to need to prompt for a login, however I can't allow any kind of linux login prompt because there's already too much things for the user to do. I editect xinitrc to automatically run /usr/lib/ICAClient/wfica . So when I type in "startx" after logging in as root I get the boot to Citrix client look. Which is exactly what I want.
However to get that far I have to log in as root. I need the distro to simply load up and go directly to launching the /usr/lib/ICAClient/wfica binary. I've tried adding /usr/X11R6/bin/startx to the inittab in which case I get a ton of errors. The X server starts but then errors with an "ApplicationServer" not defined or something like that. However after the computer loads and I login as root, I can run startx just fine?
It looks to me like the system doesn't know where the files are, I went ahead and exported a bunch of directories as a test and I got a different set of errors, but it looked like it was partially resolved, but the Xserver still crashed cause of the errors.
Does anyone have an idea of how to get 'startx' to run upon boot without the massive errors?
I played a bit with kdm but I had an error about "wmaker" file could not be opened, and I have the "wmaker" package installed! (I believe I was trying to run icewm as the desktop manager)
I tried adding "local" to /etc/init.d/ with an entry of "exec /usr/X11R6/bin/startx" to no avail as I read up that Debian uses that file as opposed to rc.local
(I'm a Debian noob b.t.w)
Thanks for any help you guys can provide, hopefully by tomarrow!![]()
--j2
Hello again,
Just wanted to let you guys know not to bother with this issue anymore. I finally resolved it by implementing a shell script![]()
--j2

Dell EMC PowerEdge R740 8 Bay Server w/ 32GB RAM 2x GOLD 6132 2x 1600W PSU H730p
$499.88
Dell EMC PowerEdge R440 Xeon silver 4215 2.5GHz 16 GB ram 2x 550W PSU No HDD
$275.00
Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Cores / 64gb / Raid / 2x 1Tb
$374.99
Dell PowerEdge R730XD 28 Core Server 2X Xeon E5-2680 V4 H730 32GB RAM No HDD
$378.93
Dell PowerEdge C4130 1U AI GPU Server | 2x E5-2680 v3 | 32gb Ram | 2x 1600W
$409.99
Dell Poweredge R630 2x Xeon E5-2680 v3 2.5ghz 24-Core | HBA330 | No RAM or HDD
$149.99
Dell Poweredge R730xd 12LFF 2*2660v4 4*1Gbe h730 2x 750W Server CTO
$488.00
Dell Poweredge R810 4x Xeon X7560 2.26ghz 32-Cores | 256GB | 3x Trays | H700
$289.99
Dell Poweredge R620 10x 2.5" bay with 256GB (16x16gb) DDR3, 2x E5-2690v2, H710
$349.99
Dell EMC VxRail E560F 10-SFF 2*Gold 6230R 2.1GHz No RAM HBA330 iDrac Ent Server
$349.99