So I ran the knoppix-installer script and successfully got a working Knoppix filesystem installed onto my USB hard disk, /dev/sda2. The phase of the installation where the boot disk is created failed, which is no big problem since I don't think this machine can boot from a USB floppy.

My plan was to boot from the CD again with the boot command "knoppix root=/dev/sda2". This doesn't work - Knoppix just boots into it's regular mode, using the uncompressed root drive image.

It's as if the kernel ignores the root= parameter.

I can actually boot from a Gentoo CD with the LILO command "gentoo root=/dev/sda2" and this *works*. So I know that the hard drive install worked correctly.

Anyone know why I can't get the parameter to be adhered to? Thanks.