Results 1 to 3 of 3

Thread: unable to access sfs file system with critcal data!!!

  1. #1
    Junior Member
    Join Date
    Mar 2004
    Posts
    3

    unable to access sfs file system with critcal data!!!

    situation is as fallows
    a pc containing 1 ide drive and 4 scsi drives
    hda1 is the OS drive, i copy crital data from hda1 to sda1
    i wipe out the os drive and reinstall knoppix, had some troubke with the install so now im booted from the knoppix 3.3 cd
    i try to mount sda1 and i get
    mount /dev/sda1 /mnt/sda1
    mount: /dev/sda1 is not a valid block device

    acording to cfdisk sda1 is a sfs partition
    i have never heard of this until now
    -----------------------------------
    "fdisk -l /dev/sda" returns

    Disk /dev/sda: 9150 MB, 9150996480 bytes
    255 heads, 63 sectors/track, 1112 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 1112 8932108+ 42 SFS
    -------------------------------------
    "file - </dev/sda1" returns
    bash: /dev/sda1: No such device or address
    --------------------------------------
    "cat /proc/partitions" returns
    major minor #blocks name

    8 0 8936520 sda
    8 16 8936520 sdb
    8 32 8936520 sdc
    8 48 8936520 sdd
    3 0 78150744 hda
    3 1 1502077 hda1
    3 2 76646083 hda2
    --------------------------------------------
    this is a friends server box...
    i came out to install a newer version of knoppix for him so he would not be running the web server with an old kernal
    i have no idea how retrive the data from sda1 that was wriiten to it with the prior knoppix install
    i have no idea what sfs is or why the file system was made as sfs in the 1st place..
    all i know is that if that partition can somehow be mounted, with knoppix or any other tool out ther, i need to find out how to do it
    can anyone shed any light on this extensivly confusion situation?
    -evermuse

  2. #2
    Senior Member registered user
    Join Date
    Feb 2004
    Posts
    949
    try to mount /dev/sda instead of sda1

  3. #3
    Junior Member
    Join Date
    Mar 2004
    Posts
    3
    "mount /dev/sda /mnt/sda1" returns
    mount: you must specify the filesystem type

    so then..
    "mount -t sfs /dev/sda /mnt/sda1" returns
    mount: fs type sfs not supported by kernel


    the thing is i mounted this fs with the install of knoppix that was just on the drive...

    an older version of knoppix 3.3
    im booted on the latest 3.3 iso right now

    could the older 3.3 have sfs support while the latest does not?

    that doesn't make much sence to me
    none of this does... i need this data
    -evermuse

Similar Threads

  1. NTFS is seen as FAT32-cant access data
    By mobilesoul in forum MS Windows & New to Linux
    Replies: 13
    Last Post: 10-16-2005, 04:58 PM
  2. Kernel panic: Unable to mount root file system on block....
    By wquay in forum Hdd Install / Debian / Apt
    Replies: 1
    Last Post: 06-23-2005, 06:22 AM
  3. Unable to access CD/DVD drive
    By StumpMan in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 05-15-2005, 03:03 AM
  4. unable to make install - read-only file system
    By knopppixnewbie in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 01-24-2005, 04:18 PM
  5. access to local file system
    By warwick in forum General Support
    Replies: 1
    Last Post: 01-01-2003, 02:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


IBM System X3850-X5 Server w/4x Intel  Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD picture

IBM System X3850-X5 Server w/4x Intel Xeon E7-4870 CPU , 512 GB DDR3 RAM,NO HDD

$1299.99



DEFECTIVE IBM SYSTEM X3530 M4 7160AC1 Server 2INTEL XEON E52430L 0 80GB  G3D picture

DEFECTIVE IBM SYSTEM X3530 M4 7160AC1 Server 2INTEL XEON E52430L 0 80GB G3D

$142.50



Unused IBM 09P0037 MAINBOARD For  RS/6000 7044-170 P-Series picture

Unused IBM 09P0037 MAINBOARD For RS/6000 7044-170 P-Series

$375.00



IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5

IBM QRadar xx29 2x Xeon E5-2650v4 2x 900W PSU M5120 12x 3.5" Bay Server No RAM

$179.99



IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES picture

IBM SYSTEM X3500 M3 SERVER 7380AC1 TOWER Server XEON E5620 8GB RAID SEE NOTES

$110.30



IBM 02YC027 Seagate ST2400MM0129 2.4TB 10K SAS 12Gb/s 2.5

IBM 02YC027 Seagate ST2400MM0129 2.4TB 10K SAS 12Gb/s 2.5" Server Hard Drive

$200.00



Compaq ProLiant 1500R 5/100 rack server, Series 3155, with IBM 2.1GB HD, VINTAGE picture

Compaq ProLiant 1500R 5/100 rack server, Series 3155, with IBM 2.1GB HD, VINTAGE

$295.00



IBM Power S824 12Bay 4U Server - 2x Power8 CPU, 512GB DDR4, MT: 8286-42A picture

IBM Power S824 12Bay 4U Server - 2x Power8 CPU, 512GB DDR4, MT: 8286-42A

$1731.00



IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon  E5620 picture

IBM ADP Server Type 7870 AC1 NO HDD | 128GB RAM PC3L | 2 x Xeon E5620

$199.99



Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs picture

Rare Vintage IBM 93ZZ PowerPC Server Board - MCM Ceramic CPU - 40N1844 - 1.1 lbs

$49.99