Currently if you have myconf=scan (or one of the equivalents =scan) then you will get an error message about failing to mount /dev/ as AES256 (really annoying if you've used splash as if seems to lock the machine), the problem being that knoppix-autoconfig doesn't check to see if it found a config and hence tries to mount an invalid point. A small patch to knoppix-autoconfig will sort it out. Find the following section:
Code:
MYCONFDIR="$(findfile knoppix.sh)"
MYCONFDEVICE="${MYCONFDIR##/mnt/}"
MYCONFDEVICE="/dev/${MYCONFDEVICE%%/*}"
MYCONFMOUNTPOINT="/mnt/${MYCONFDEVICE##/dev/}"
MYCONFDIR="${MYCONFMOUNTPOINT}"
And change it to:
Code:
MYCONFDIR="$(findfile knoppix.sh)"
if [ -n "$MYCONFDIR" ]; then
MYCONFDEVICE="${MYCONFDIR##/mnt/}"
MYCONFDEVICE="/dev/${MYCONFDEVICE%%/*}"
MYCONFMOUNTPOINT="/mnt/${MYCONFDEVICE##/dev/}"
MYCONFDIR="${MYCONFMOUNTPOINT}"
else
FOUND_CONFIG="none"
fi