I accidentally removed my /boot/initrd.gz and now my Knoppix install won't boot.

The error I get at boot time is:

kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno = 2
VFS: Cannot open root device "802" or 08:02
Pelase append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:02

This is the stock 2.4.24-xfs kernel and I tried recreating it by running "mkinitrd -o /boot/initrd /lib/modules/2.4.24-xfs" but that doesn't appear to be the same way the original initrd was created.

Does anyone know how the original /boot/initrd was created?

Thanx