Hi
I have the same error after editied miniroot.gz.. I think it comes from cloop.. did you find any solution ?
Hello
I have made a lot of progress customizing knoppix and now I have gnome 2.2 with BlueCurve, XFree4.2.99 and a trimmed size to 384 MB... I created the image file as mentioned in this tutorial http://gnubox.dyndns.org:8080/~sunil/knoppix.php
When I try to boot to knoppix with the 384 MB KNOPPIX file in /dev/hda3/KNOPPIX (ext2 partition), I get this error:
------------------------------------------------------------------
Accessing KNOPPIX CDROM at /dev/hda3...
Starting init process.
INIT: version 2.78-knoppix booting
Activating swap...
Checking root file system...
fsck 1.32 (09-Nov-2002)
fsck.ext2: Is a directory while trying to open /
/:
The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap), the filesystem is corrupt, try to manually repair and reboot.
e2fsck -b 8193 .... <-------This command doesn't make any difference...
CONTROL-D will exit and REBOOT the system:
root@(none):/#
------------------------------------------------------------------
Any ideas?[/url]
Hi
I have the same error after editied miniroot.gz.. I think it comes from cloop.. did you find any solution ?
Did anyone come up w/ a solution for this? If so, what is it?
Thanks,
cesman
I've same problem .I've removed /etc/fstab but nothing happens![]()
i have been recently working with creatin a kernel 2.6.4 for a Live CD.
me and the team of developers im working with experienced a similar problem wen booting from an hard drive install of our new kernel.
we found that the solution was to alter the /etc/fstab.
the line that states about your hard drive may have a 0 1 at the end.
if you change this to 0 0 it may work
i wood have put exactly how it would look but i aint got access to a Linux comp at the mo and cant remeber it off hand
hope my description helps
ryan
Thanks. May be my problem was i've to run knoppix-autoconfig *before* another script, I've done a symlink from /etc/init.d/knoppix-autoconfig to /etc/rcS.d/S00knoppix-autoconfig and now it works fine!
The harddisk init scripts seems to be no the same from CD scripts.

Windows XP, Vista, 8.1, Linux Knoppix, Office XP, (6 CDS)
$10.00
KNOPPIX 9.1 Linux Install & Live DVD 32bit & 64bit
$19.99
KNOPPIX USB DVD OS , BEST OF ALL HIGHLY RECOMENDED
$11.99
Knoppix Live GNU Linux System 9.1 on Bootable CD / DVD / USB Flash Drive
$5.99
Knoppix Linux Bootable OS v8.6 "Original Live Operating System" 16G USB Stick
$20.85
$8.00
VINTAGE SOFTWARE | KNOPPIX STD 0.1 (SECURITY TOOLS DISTRIBUTION)
$7.57
Knoppix Linux Bootable OS v8.6 "Original Live Operating System" 32G USB Stick
$21.42
$7.00
Knoppix 5.0.1 ULTRA RARE Linux DVD - Linux Pro Extra August 2006
$33.98