Hi
I have the same error after editied miniroot.gz.. I think it comes from cloop.. did you find any solution ?
Hello
I have made a lot of progress customizing knoppix and now I have gnome 2.2 with BlueCurve, XFree4.2.99 and a trimmed size to 384 MB... I created the image file as mentioned in this tutorial http://gnubox.dyndns.org:8080/~sunil/knoppix.php
When I try to boot to knoppix with the 384 MB KNOPPIX file in /dev/hda3/KNOPPIX (ext2 partition), I get this error:
------------------------------------------------------------------
Accessing KNOPPIX CDROM at /dev/hda3...
Starting init process.
INIT: version 2.78-knoppix booting
Activating swap...
Checking root file system...
fsck 1.32 (09-Nov-2002)
fsck.ext2: Is a directory while trying to open /
/:
The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap), the filesystem is corrupt, try to manually repair and reboot.
e2fsck -b 8193 .... <-------This command doesn't make any difference...
CONTROL-D will exit and REBOOT the system:
root@(none):/#
------------------------------------------------------------------
Any ideas?[/url]
Hi
I have the same error after editied miniroot.gz.. I think it comes from cloop.. did you find any solution ?
Did anyone come up w/ a solution for this? If so, what is it?
Thanks,
cesman
I've same problem .I've removed /etc/fstab but nothing happens![]()
i have been recently working with creatin a kernel 2.6.4 for a Live CD.
me and the team of developers im working with experienced a similar problem wen booting from an hard drive install of our new kernel.
we found that the solution was to alter the /etc/fstab.
the line that states about your hard drive may have a 0 1 at the end.
if you change this to 0 0 it may work
i wood have put exactly how it would look but i aint got access to a Linux comp at the mo and cant remeber it off hand
hope my description helps
ryan
Thanks. May be my problem was i've to run knoppix-autoconfig *before* another script, I've done a symlink from /etc/init.d/knoppix-autoconfig to /etc/rcS.d/S00knoppix-autoconfig and now it works fine!
The harddisk init scripts seems to be no the same from CD scripts.

Dell 6P85J 4TB ST4000NM0063 7.2k 6Gb/s 3.5” SAS SED Hard Drive with Tray
$39.99
Western Digital HUS726T4TAL5204 4TB 7.2K SAS 12Gb/s 3.5" 512e HDD NetApp X375A
$64.00
(ST8000NM0045) SEAGATE ENTERPRISE 8TB 7200RPM 4Kn SATA 6Gb/s 3.5" HARD DRIVE
$199.99
DELL 2TB Enterprise HDD (7200RPM, 3.5", SATA III, 128MB Cache) HUS722T2TALA600
$49.95
HGST 0F23072 Deskstar NAS 6TB SATA III 7200RPM 128MB 3.5in HDD
$84.99
Seagate ST500DM009 BarraCuda 500 GB 3.5" SATA III Desktop Hard Drive
$14.99
Dell ST6000NM0034 1HT27Z-150 NWCCG 6TB SAS 3.5 7.2K ENTERPRISE SERVER DRIVE
$68.99
Seagate Exos ST2000NX0253 HDD 2TB SATA 7.2K 2.5" 512b/s
$55.00
Western Digital 1TB 3.5" SATA III 7200RPM Desktop Hard Drive
$34.99
Seagate ST12000NM0127 12TB 256MB 7200RPM 3.5" SATA 6.0Gb/s Enterprise Hard Drive
$318.99