Hi
I have the same error after editied miniroot.gz.. I think it comes from cloop.. did you find any solution ?
Hello
I have made a lot of progress customizing knoppix and now I have gnome 2.2 with BlueCurve, XFree4.2.99 and a trimmed size to 384 MB... I created the image file as mentioned in this tutorial http://gnubox.dyndns.org:8080/~sunil/knoppix.php
When I try to boot to knoppix with the 384 MB KNOPPIX file in /dev/hda3/KNOPPIX (ext2 partition), I get this error:
------------------------------------------------------------------
Accessing KNOPPIX CDROM at /dev/hda3...
Starting init process.
INIT: version 2.78-knoppix booting
Activating swap...
Checking root file system...
fsck 1.32 (09-Nov-2002)
fsck.ext2: Is a directory while trying to open /
/:
The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap), the filesystem is corrupt, try to manually repair and reboot.
e2fsck -b 8193 .... <-------This command doesn't make any difference...
CONTROL-D will exit and REBOOT the system:
root@(none):/#
------------------------------------------------------------------
Any ideas?[/url]
Hi
I have the same error after editied miniroot.gz.. I think it comes from cloop.. did you find any solution ?
Did anyone come up w/ a solution for this? If so, what is it?
Thanks,
cesman
I've same problem .I've removed /etc/fstab but nothing happens![]()
i have been recently working with creatin a kernel 2.6.4 for a Live CD.
me and the team of developers im working with experienced a similar problem wen booting from an hard drive install of our new kernel.
we found that the solution was to alter the /etc/fstab.
the line that states about your hard drive may have a 0 1 at the end.
if you change this to 0 0 it may work
i wood have put exactly how it would look but i aint got access to a Linux comp at the mo and cant remeber it off hand
hope my description helps
ryan
Thanks. May be my problem was i've to run knoppix-autoconfig *before* another script, I've done a symlink from /etc/init.d/knoppix-autoconfig to /etc/rcS.d/S00knoppix-autoconfig and now it works fine!
The harddisk init scripts seems to be no the same from CD scripts.

Novell SUSE Linux Enterprise Server 9, Linux Professional 8.2 / 9.1 — 3 DVD Set
$58.00
Ubuntu Server 26.04.1 LTS Bootable USB Flash Drive – Latest September 2026
$12.99
OPNsense pfSense 8-Core Atom C3758 2.2GHz 8GB DDR4 64GB SSD 8x NIC QAT AES VPN
$115.00
RED HAT ENTERPRISE LINUX 5 SERVER RHF0382US-R1 for PC x86 AMD 64 INTEL 64 30 Day
$188.24
OPNsense Firewall VPN QAT 8-Core Atom C3758 2.20GHz 16GB DDR4 128GB SSD 8xNIC
$175.00
All New Ubuntu 26.04 LTS Linux Bootable USB Flash Drive
$15.95
1U Rackmount PC Intel Core i5-2520M 8GB RAM 500GB HDD Ubuntu Linux Server
$109.99
ZimaBoard 2 1664 Home Server 16GB
$350.00
Microsoft SQL Server 2019 Enterprise 40 Core Unlimited CAL Retail License FPP
$299.00
SQL Server 2022 Enterprise 96 Core License & DVD Unlimited CALs with CoA
$284.99