Hello!

I started knoppix with the 2.6 kernel on my labtop
(the ct' editions 2.6 didn't load). As reported by others I got
a scsi-error and a segfault. Loaded with option "knoppix noscsi" and worked.

Started knoppix-installer in debian-mode and rebooted.
"uname -a" showed the 2.4 kernel again.
However the knoppix-installer configured /etc/lilo.conf
with boot options for the 2.4 and 2.6.5 kernels.

I opend lilo.conf and looked for the entry /boot/vmlinuz-2.6.5
which has:
append="ramdisk_size=100000 ... ... ... "
changed it to
append="ramdisk_size=100000 ... ... ... noscsi"

now I run "lilo" and rebooted.
Nice lilo boot-menu, now I can choose the 2.4 kernel or the
2.6.5 kernel.

Stephan