From what the Captive download page says, and the Captive support/bug mailing list says, there's issues both with the Debian packages themselves, and the gnome-vfs-http handler included with the current version of Gnome.

Captive's author recommends one install the static package (which includes nice install and uninstall scripts), instead of the current *.deb archives, or you'll get these "libntfs" and "httpcaptive" errors. Of course, you can't do that from the live Knoppix CD, due to its read only file system.

The "httpcaptive" errors would seem to mean that you won't be able to download the necessary files from Microsoft using "captive-install-acquire". But you can still install the necessary files if you've got Windows XP installed on a partition the Captive installer can "see".

The Captive mailing list seems to indicate that, when you change or create a file on an NTFS partition, the changes don't get written until you unmount the partition. It also seems to indicate that a GUI-based file manager (like Konqueror) will open all the files it "sees" on an NTFS partition (e.g. to look for icons inside them; to look at their sizes; etc.), which can use up tons of memory, since the files don't get closed. You could run out of resources. Which means that your best bet with is to stick to accessing your NTFS volume from the command line.

Yes, you can mount an NTFS partition in fstab. But you'll probably lose any changes you make to it unless you unmount it before you shut Linux down. From the Captive support mailing list:

"You would have to create some /etc/init.d/captive script to unmount captive
devices. Otherwise the Captive processes get killed during the shutdown sooner
than it is able to unmount and commit the changes to the disk.