PDA

View Full Version : NX 'session startup failed'



dpthompson
01-12-2007, 11:40 PM
Hi all,

I have Knoppix 5.1 running, and NX Server , but I cannot establish an NX session. I am running NX client 2.1.0-11 on Windows XP. Here's what happens:

1) I can start NX server (using default keys)
2) I can connect successfully with the client from my windows machine
3) I can authenticate successfully
4) Then I always get the message "Session startup failed."

From the Details window, I don't see any messages that might explain what the problem is. Everything seems to go fine until:

NX> 504 Session startup failed.
NX> 1004 Error: nxagent failed to start with: Unrecognized option: 1
NX> 105 /usr/lib/nx/nxserver: line 891: 4516 Terminated ( sleep $AGENT_STARTUP_TIMEOUT; exit 1 )
NX> 1001 Bye.
Killed by signal 15.


Can anyone suggest any tips?

Thanks!!

Dennis Thompson

rduke15
02-03-2007, 04:00 PM
Similar problem for me. Knoppix 5.1.1. NX client version 2.1.0-16 on XP SP2:

After the "Authentication completed" message, I get "Connection timeout". Clicking "Details" shows the log, which ends with:



NX> 105 startsession --link="adsl" --backingstore="1" --nodelay="1" --cache="8M" --images="32M" --media="0" --session="knoppix-208" --type="unix-kde" --cookie="******" --geometry="fullscreen" --kbtype="pc102/fr_CH" --screeninfo="1024x738x32+render"

NX> 1000 NXNODE - Version 1.4.0-45-SVN OS (GPL)
NX> 700 Session id: Knoppix-1000-B7895CB8C5691116B2A5D51A4CEEF250
NX> 705 Session display: 1000
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: 4c4ca0991571f846903cabf54f4a3deb
NX> 702 Proxy IP: 192.168.1.57
NX> 706 Agent cookie: 4c957089292551ec9d7adf2c0dac4d8e
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 0
/usr/lib/nx/nxserver: line 891: 4192 Terminated ( sleep $AGENT_STARTUP_TIMEOUT; exit 1 )
NX> 105 NX> 504 Session startup failed.
NX> 1004 Error: nxagent failed to start with: Unrecognized option: 1
NX> 1001 Bye.
Killed by signal 15.