PDA

View Full Version : Error setting up re-master session



WallyWallWhackr
04-21-2008, 03:10 AM
Hey guys,

I have a re-master session going. I copied all the files over, and upon issuing the bind commands before the chroot, I get an error when binding the /dev directory. It says that the file system is wrong. Is this a familiar error you can help me with, or do I need to post the entire error message?

Thanks. :D

rogerr
04-22-2008, 05:51 PM
Hi

I think I am getting the same error as you. Do your responses look like this?

#mount --bind /dev /media/sda1/knoppix-tmp/source/KNOPPIX/dev
mount: wrong fs type, bad option, bad superblock on /dev,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so


# dmesg | tail
lo: Disabled Privacy Extensions
ADDRCONF(NETDEV_UP): eth0: link is not ready
PCI: Setting latency timer of device 0000:00:02.0 to 64
[drm] Initialized i915 1.6.0 20060119 on minor 0
eth1: no IPv6 routers present
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
EXT3 FS on sda1, internal journal
ipw2200: Firmware error detected. Restarting.
ipw2200: Firmware error detected. Restarting.

WallyWallWhackr
04-23-2008, 07:01 AM
Hi

I think I am getting the same error as you. Do your responses look like this?

#mount --bind /dev /media/sda1/knoppix-tmp/source/KNOPPIX/dev
mount: wrong fs type, bad option, bad superblock on /dev,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so


# dmesg | tail
lo: Disabled Privacy Extensions
ADDRCONF(NETDEV_UP): eth0: link is not ready
PCI: Setting latency timer of device 0000:00:02.0 to 64
[drm] Initialized i915 1.6.0 20060119 on minor 0
eth1: no IPv6 routers present
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
EXT3 FS on sda1, internal journal
ipw2200: Firmware error detected. Restarting.
ipw2200: Firmware error detected. Restarting. Yes, I am getting the same error. The first part you wrote, not the tail data.

Perhaps what we need to do is try a different volume/partition for the source/master session writes to reside.

rogerr
04-25-2008, 05:13 PM
After 40 google searches I found this link:

http://www.knoppix.net/wiki/Dev_null_permission_denied

Hasn't helped my problem. But you may find it useful.

WallyWallWhackr
04-27-2008, 07:48 AM
Is there no persons out there that have experienced this mount --bind error when remastering the DVD?
I can't believe that this has not been resolved.

I also wonder what I did in succeeding to make an 8GB USB drive carry the DVD image and additional apps.

It was on 5.2 and I cannot remember what I did to get it all onto a USB drive and make it bootable.

Also... how do I edit the installed application scenario while booted to the USB drive? It makes the partition read only.

rogerr
04-28-2008, 01:01 AM
Using the link I posted Friday, I was able to get chroot to work. For whatever reason, I can ignore "mount --bind /dev ..........." .

Before mounting, it is necessary to make the change to /etc/fstab. Then mounting /proc and /sys seem to be enough for my system.

Still playing with the configuration. Have not tried to burn the new iso yet.

WallyWallWhackr
04-29-2008, 01:39 AM
Using the link I posted Friday, I was able to get chroot to work. For whatever reason, I can ignore "mount --bind /dev ..........." .

Before mounting, it is necessary to make the change to /etc/fstab. Then mounting /proc and /sys seem to be enough for my system.

Still playing with the configuration. Have not tried to burn the new iso yet. I get a feeling that the way they mount the DVD image as a CD (ISO9660) file system might be the reason. DVDs are UDF, filesystem IIRC. The error is with mount. Perhaps forcing it might work, but I was more interested in someone here knowing what was going on from prior experience. I cannot imagine that I am the first one to see this.

I suspect that since all the scripts and documents about remastering are about two releases old (at least), that someone (we) need to re-vamp a lot of said documents.

How hard would the automated script be to make it examine which version of Knoppix is running and branch to the appropriate script segment?

Somehow, I get the feeling that I will be invited to make such changes. I do not think I have the time or experience, however. It would be more appropriate for one of your gurus to do it.

Is there a command to test for Knoppix version, or do we parse the uname kernel data to decide?

I skipped the remaster session so far, and went straight to setting up a 5.3.1 8GB USB drive with SDLMAME on it

Oh well... enough ranting. Someone(me?) should write a comprehensive script that is so good at setting up remastering that klaus would do a final edit on it and include it on his releases. :-] :D