Knoppix 3.4 HD install LiLO problem ...
Hello all:
After downloading the new Knoppix 3.4 CD and thoroughly trying the Live version out with both the 2.5 and 2.6.5 versions of the kernel, I went on to do a hard disk install with the new knoppix-installer script.
As expected everything went off quite well and besides having to modify the vga=xxx entry (to 'normal') in the lilo.conf file and having to manually start CUPS, there were no major surprises.
I had already practised a lot with the Knoppix 3.3 CD. ;-)
The rig is composed thus:
First drive SCSI
sda1 W2000
sda5
Second drive SCSI
sdb5
sdb6
Third drive SCSI
sdc1
sdc2
sdc3
Fourth drive
sdd5 IDE HDD FAT32 in a USB 2.0 enclosure.
The Knoppix install is on the third SCSI drive (sdc1) and LiLO is on the first SCSI drive's (sda1) mbr.
At boot, besides the W2000 option at sda1, LiLO offers three additional options:
Linux
Linux (2.4)-1
Linux (2.6)-2
The first and the second options boot into kernel 2.4 with this error message:
mount: fs type devfs not supprted by kernel.
The third option does not boot and gives the following error message:
pnp: unable to assign resources to device 01:01.01.
Kernel panic: VFS:unable to mount root fs on unknown block(8.33)
From there, only a hard reset gets me out.
It would seem to me that this is a LiLO problem as the Live CD works perfectly well with both kernel options.
It is at this point that my first question comes up:
Why are there 'three' options (instead of just the two kernels) to boot into Linux?
I'd expect just two, 2.4 and 2.6.
The first two have apparently the same effect and boot into 2.4.26 although the corresponding entries in the
lilo.conf file point to different kernel images:
Label='Linux'
/boot/initrd.img
Label='Linux (2.4)-1'
/boot/initrd.img-2.4.26
Curiously enough, the third option ...
Linux (2.6)-2
... does not point to any image at all, the space is just blank.
If I add what would seem to be the correct line: (which is an existing image file)
/boot/initrd.img-2.6.5
LiLO will balk when run and say:
Fatal: empty map section.
My second question is:
How to solve the problem presented by 'mount: fs type devfs not supprted by kernel problem'?
Is it a problem at all?
And the last and most important question ....
How can I fix this so as to be able to boot into the 2.6.5 kernel?
Ahhh ...
Another last one ;-)
KMix loads along with X ...
Can't find where to tweak so as to stop it from loading.
Thanks in advance.
CIV